0

This is exactly the same issue that I am facing.

Almost similar question here as well.

I have tried all the answers published in the related "StackExchange" questions. I also have tried to increase the Rows and Columns count both using PuTTY settings window and stty. No luck so far. Hence I am creating this question.

Required details for diagnosis :

root@MyUnit:/#echo $PS1
\u@\h:\w\$
root@MyUnit:/#shopt checkwinsize
checkwinsize    on
root@MyUnit:/#stty -a
speed 115200 baud; rows 60; columns 150; line = 0;

If this information is of any use : I am using PuTTY to connect a Linux device in serial mode via a FTDI USB-Serial Converter.

  • Do the rows and columns reported by stty match the reality of your PuTTY window? – roaima Oct 3 '19 at 22:10
  • @roaima : Yes, they do match. – Gavi Oct 3 '19 at 22:45
  • If you set the prompt to something simple, ie PS1="# " do you still have the issue? – roaima Oct 3 '19 at 22:58
  • Your Q says that you're not able to type more than 80 characters in the line, but the linked Qs all talk about the prompt not being able to wrap correctly. Which is it? What does echo $TERM say? If it's xterm, linux or vt100, change it to putty. Also try turning automatic margins on with tput smam. – mosvy Oct 4 '19 at 5:15
  • @roamia :Yes, I have the issue with PS1="# " as well. – Gavi Oct 4 '19 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.