0

I installed ibus and trying ibus-avro to write bengali in libreoffice writer. I generally write with Noto Sans Bengali font. But while I ma starting writing the font is automatically changing into freesans. Why is this happening and how to fix this?

migrated from raspberrypi.stackexchange.com Oct 3 at 16:51

This question came from our site for users and developers of hardware and software for Raspberry Pi.

  • When does it automatically change? LibreOffice can be set up to, for example, automatically change from one style to another when you end a paragraph. Could that be what's happening? – derobert Oct 3 at 17:08
  • Yes something like that. How to stop that? – Sohan Arafat Oct 3 at 18:55
1

A LibreOffice style can be set to activate a different style when you start a new paragraph. This setting is in the style edit box (e.g., from Styles→Edit Style...), on the Organizer tab. The setting is "Next Style". To not change to a different style, pick the same style (e.g., "Default Style"'s normal next style is "Default Style").

It probably makes sense to set up a style for your Bengali text, where you can set both the font and the language on the "Font" tab. (Setting the language will help e.g., prevent spell check from thinking it's English or whatever yours defaults to). Then you can set the "Next style" to the same style. You can easily create new styles from Styles→Manage Styles (which is keyboard shortcut F11 here).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.