0

yesterday i got a new UX433F zenbook and since i had no data on it, i decided to try some other distros.

i installed ubuntu 2 or 3 times, then tried to install arch and did it, and then i installed Kali.

between this installing i may have deleted all partitions using fdisk. after installing Kali, the laptop freezes at "loading initial ramdisk..." and after some searching I tried adding "nomodeset" to the commands and nothing happened.

then i decided to install Ubuntu again, and when i hit "install ubuntu", a black page is there and nothing happens, again, i have tried "nomodeset" here too. when i wanna install arch, page freezes in "SHA256 validated" and then nothing happens.

i can install kali again, but everytime it got stuck in the same "loading initial ramdisk..." After the installation has ended successfully.

i can NOT use live OS of any if the above images, it freezes too. i use rufus 3.8 on windows 10 to create bootable USBs, and my images are : "kali-linux-2019.3-amd64.iso", "archlinux-2019.10.01-x86_64.iso" and "ubuntu-18.04.3-desktop-amd64.iso". i guess the problem is about the partitions, or/and the grub, but i dont know how to confirm or fix this.

i've used linux and ubuntu before, but i dont consider myself a pro, and any help is really appreciated. if you need any more details. just tell me. thanks.

  • What exactly do you see when your laptop is powered on? – Wildcard Oct 3 '19 at 15:16
  • @Wildcard when i turn on the laptop, kali is installed, so i see the grub2 menu to choose kali and blue dragon in the background. – m4jiz Oct 3 '19 at 15:21
  • And what happens if you choose Kali in the grub menu? Also, do you have any other choices listed? – Wildcard Oct 3 '19 at 15:25
  • @wildcard as i said in the question, it freezes after echoing "loading initial ramdisk...", my options are : Kali GNU/Linux, Advanced options for Kali GNU/Linux, System setup – m4jiz Oct 3 '19 at 22:46
  • 1
    It's a bit confusing, currently. Could you please edit your question so that the many mentions of "installing" accurately reflect whether you meant "installing" or "booting"? Did you actually go through the full Ubuntu install procedure 2 or 3 times, or did you select it in grub 2 or 3 times? – Wildcard Oct 3 '19 at 23:23
3

I had EXACTLY the same issue as you described, down to the tee. I had to make an account just to let you know my brother!

After much frustration, i have found a permanent solution. You need to flash the BIOS. My BIOS was version 301, and when i download version 309 and applied it, now everything works correctly, i can install the latest version of Kali, AND it boots!

Plenty of advice on flashing the BIOS out there. But disclaimer! Once you do this you cannot go back (easily), and you do this operation at your own risk.

Make sure you download the correct BIOS for your laptop (some similar ones out there), unzip and place the file onto a USB drive. Load into system setup (F2 @startup). Go to the Ez Flash Utility and select the file. Once done, it will work for you I'm sure.

Enjoy!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.