0

Been using samba on my Linux Mint machine to map to a windows network drive of a large university for a couple of years. Has always worked.

Linux Mint version: 18 (Sarah)
Kernel: 4.4.0-164-generic
Samba version: Version 4.3.11-Ubuntu

I use their VPN and then map to the samba with:

smb://DOMAIN;user@subdomain.address.edu/ssd_drives_k/my/path/to/files

This has worked for ages; but recently the problem has arisen that I can only read (and therefore open/copy) some files but not others. I can see everything in nemo but some files (of all types, word, pdf, etc) WILL NOT copy to my computer or open in their respective program. There doesn't seem to be any particular pattern as to which files it affects but basically some are visible but inaccessible to me.

The error I get on those files is "Function not implemented", for example:

  1. When trying to copy some files to my desktop gives "Function not implemented" error window (i.e. "Error while copying FILE/PATH"; There was an error while copying the file into /path/path"; and then Cancel or Skip options - "Show more details" says "Function not implemented").

  2. When trying to open some pdfs gives "Function not implemented" in my pdf reader (that is the default system reader; if I try okular it simply doesnt open and no error).

Error screenshot:

enter image description here

Hence, there's a bunch of stuff I can no longer access... The IT team at the university are normally really great but in this instance have just left me hanging with nothing... frustrating but I wondered if anyone here might be able to help answer what is causing this and how to correct it?

1
0

Thanks to this answer I have deduced a solution: https://serverfault.com/questions/414074/mount-cifs-host-is-down/929331#929331

Not sure why but I suspect an upgrade in my computer of SMB has meant I am no longer compatible with their (older?) version.

This now works if I do it manually in the terminal and specify vers = 1.0:

sudo mount -t cifs //subdomain.address.edu/ssd_drives_k/my/path/to/files /mnt/driveiwant -o username=user,domain=DOMAIN,vers=1.0

But vers=3.0 doesn't work:

sudo mount -t cifs //subdomain.address.edu/ssd_drives_k/my/path/to/files /mnt/driveiwant -o username=user,domain=DOMAIN,vers=3.0

So it seems they need to upgrade their gear maybe, I am not sure, but this works!

2
  • SMBv1 has serious security vulnerabilities. It was the main attack vector of the "original" WannaCry ransomware. If the remote server does not even support SMBv2 (vers=2.0 for mount -t cifs), it's probably an old Windows Server 2003 system or some NAS system with an out-of-date SMB implementation. – telcoM Oct 2 '19 at 12:43
  • Thanks - a very useful observation. I will try and use v2 and warn them they shouldn't be supporting 1. – the_t_test_1 Oct 2 '19 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.