3

I have set the windows key to open the start menu and many different combinations with the windows key for different things such as win+T for opening terminal, win+E for opening file explorer. The issue is that whenever I use windows key for other such combination, the start menu always gets open.

For example: win+T opens terminal and start menu, win+E opens file explorer and start menu again simultaneously.

How to remove this?

Edit: I don't want to change the shortcut keys, I know how to do that. I just don't want the key1 [+key2] individual shortcuts to execute when I'm pressing key1+key2+key3

2
  • which desktop environment are you using? Oct 2 '19 at 7:49
  • XFCE currently, but I'm planning to switch to GNOME. So if possible, could you tell for both? @DonaldLWilson
    – sh.3.ll
    Oct 2 '19 at 8:00
2

Keyboard Shortcuts in XFCE
In your panel, Applications -> Settings -> Keyboard.
Open the Application Shortcuts Tab.

XFCE Keyboard Shortcut

Look for the the Super(Windows) + T key combination.
You can double click to edit it to something else or browse through to see if there are any duplicates.
Also make sure your holding down on the windows key while your simultaneously pushing the T.

For Gnome or others
Go to Settings.

Settings

Click on Devices located at the bottom of the Settings app.

Devices

click on Keyboard.

Keyboard

The right pane displays all the keyboard shortcuts that exist in your system.

Double-click on the Home folder then press the Super key (Windows key) and E together. You should see it getting assigned immediately. Click Set and close the settings app.

enter image description here

That should take care of it.

Other useful resources:
X keyboard extension
Xorg/Keyboard configuration
Extra keyboard keys

12
  • In windows, when you press win+E, it opens just the file explorer and not the start menu, right??? I want the same thing here, I don't want the start menu to pop up everytime I open file explorer or use win+R, win+TAB, etc.
    – sh.3.ll
    Oct 2 '19 at 8:43
  • What happens if you remove the keyboard shortcut assigned to just the Win key, does this remove the problem? Not sure why your start menu would be opening along with all the other shortcuts? Oct 2 '19 at 9:00
  • Try and reassign the XFCE menu to another key; Try and use the “menu” key and see if that helps. forum.manjaro.org/t/shortcuts-with-win-button-super/8800/4 Oct 2 '19 at 9:06
  • If I change the shortcut key, then it's fine. But I don't want to. It's annoying to close the start menu everytime I open a terminal or file explorer.
    – sh.3.ll
    Oct 2 '19 at 9:07
  • Tried reassigning as well, didn't work. Changing to menu key is fine, but I wanna solve the issue, not workaround it. @DonaldLWilson
    – sh.3.ll
    Oct 2 '19 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.