1

I've recently been forced to upgrade laptops after an unexpected deluge killed my last one. My wife, who plans for everything, managed to score an upgrade to an HP Pavilion 15 gaming laptop, and the BIOS reports it as

HP Pavilion Gaming Laptop 15-cx0xxx

Though some googling makes me believe it's a

HP Pavilion Gaming Laptop 15-dk0010nr

The specs are identical, except the OS reports the GPU as a 1050Ti not a 1050, though I'm not too familiar with the naming conventions of NVIDIA. The specs of the 1050Ti vs the 1050 seem unimportant for the issues I'm having.

So I install Linux Mint; it doesn't like the lid switch, causing it to overheat in its protective sleeve, because it doesn't go to sleep. I was also having issues wrangling the NVIDA drivers, and the accelerometer was causing the laptop to take forever to shutdown. I turned it off, which causes my brightness keys F2 and F3 to stop functioning correctly; dmesg tells me they and the lid switch aren't mapped.

I switched to Pop!_OS since they really try to integrate the NVIDIA drivers. After the clean install it works great, I can tell the accelerometer is working because the screen rotates. Everything sleeps when the lid closes and the brightness keys function, and the processor isn't constantly overheating causing the fans to run mostly continuously. I restart the laptop and, with the exception of NVIDIA drivers, the previous problems reappear.

I hunt through dmesg and I find that the accelerometer has a good ol' fashioned failure to chooch.

[   11.500311] hp_accel: laptop model unknown, using default axes configuration
[   11.519990] lis3lv02d: unknown sensor type 0x0
[   11.519993] hp_accel: probe of HPQ6007:00 failed with error -22
[   11.536372] hp_wmi: query 0xd returned error 0x5
[   11.536403] input: HP WMI hotkeys as /devices/virtual/input/input9

I also found sometimes when I boot up the laptop the accelerometer initializes properly and everything works.

After some digging, I found it is a known bug in the kernel.

My question is, is their some sort of work around to get

  1. The lid switch working (closure of the lid triggers a sleep event, and opening the lid causes it to wake back up)
  2. Help keep the processor from constantly throttling
  3. Get the brightness keys working

What additional information do we need to find a possible work around?

EDIT/UPDATE:

My laptop battery died and when I plugged in and booted, everything works.

I saved the output of dmesg:

[   10.716618] input: HP Wireless hotkeys as /devices/virtual/input/input8
[   10.742485] hp_accel: laptop model unknown, using default axes configuration
[   10.803972] lis3lv02d: 8 bits 3DC sensor found
[   10.879745] input: ST LIS3LV02DL Accelerometer as /devices/platform/lis3lv02d/input/input10

I figured out the error code has means that some variable given by the PC is invalid. That might not be surprising to many of you but this is the deepest I've been into Linux. It's kinda exciting really.

Is there a way to force the kernel to recognize the sensor? Could this be related to needing a BIOS update?

I couldn't post the entire dmesg output here. Would it be helpful if I did post the entire output?

EDIT 2: The battery dying thing isn't a solution because on reboot the issue reappears.

Edit 3:

I have a bandaid solution, which fixes the problem. Simply forcing reboot by holding down the power button fixes the symptoms, but I hoping that someone might have a better/more permanent solution? Any ways, here's the full dmesg output when things work and when they don't. Thanks! Output from dmesg when everything is working

Output from dmesg when things aren't working

migrated from askubuntu.com Oct 1 at 22:37

This question came from our site for Ubuntu users and developers.

  • @K7AAY yes, but it breaks after reboot. It's not a parctical solution. – Mr. Mixy Oct 2 at 15:37
  • @K7AAY, I forgot pastebin existed. I don't really want to mark this solved even though I found a bandaid solution. If I hold down the power button to force poweroff, everything works on reboot, so it works but a less scuffed solution would be really appreciated. Also I'll add the working dmesg output and the broken one really soon – Mr. Mixy Oct 3 at 2:37
  • I don't think it's solved, either. I just don't have anything more to contribute; hope someone else does. – K7AAY Oct 3 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.