2

When I try to launch command from "Run command" shortcut, sometimes I face this kind of situation as the following image.

I don't understand why, but the region that "Run command" bar comes out keeps showing the cropped background screen and I cannot remove it even if I finish using the shortcut.... super annoying!

I restarted KDE plasma 5 as the following link, but it didn't help.

https://askubuntu.com/questions/481329/can-i-restart-the-kde-plasma-desktop-without-logging-out

I would like to know how to restart the "Run command" shortcut, and erase this annoying background screenshot.

Thanks.

enter image description here

1 Answer 1

6

The "run command" part is called krunner.

The easiest way I can come up with is to kill the process (killall krunner/ps x->kill <pid>) and then restart it with e.g. nohup krunner & from a terminal.

2
  • Thanks, perfect solution!
    – eng27
    Sep 27, 2019 at 7:18
  • Worked for me. killall krunner. I didn't even have to start it manually. The next time I pressed Alt-Space it ran again with the settings changes I had added to ~/.config/krunnerrc
    – Vince
    Sep 5, 2020 at 1:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .