4

I describe what I exactly did :

First , I installed debian10-netinstall.

Then I installed Gnome via 'Tasksel' command.

Then I used this Tutorial for installing vnc server. Then I start vncserver via this command tightvncserver -geometry 1024x720 :1 and here is the output :

New 'X' desktop is debian:1

Starting applications specified in /home/parsa/.vnc/xstartup
Log file is /home/parsa/.vnc/debian:1.log

And here is the ~/.vnc/debian:1.log :

parsa@debian:~$ tail -f .vnc/debian\:1.log
26/09/19 11:41:12 Xvnc version TightVNC-1.3.9
26/09/19 11:41:12 Copyright (C) 2000-2007 TightVNC Group
26/09/19 11:41:12 Copyright (C) 1999 AT&T Laboratories Cambridge
26/09/19 11:41:12 All Rights Reserved.
26/09/19 11:41:12 See http://www.tightvnc.com/ for information on TightVNC
26/09/19 11:41:12 Desktop name 'X' (debian:1)
26/09/19 11:41:12 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
26/09/19 11:41:12 Listening for VNC connections on TCP port 5901
# Failed to parse arguments: Unknown option --login

As you can see in the last line there is an Error.

I fixed that by commenting the line contains "--login" in this file :)) /usr/bin/x-terminal-emulator

Then I restarted the vncserver :

parsa@debian:~$ tightvncserver -kill :1
Killing Xtightvnc process ID 910
parsa@debian:~$ tightvncserver -geometry 1024x720 :1

New 'X' desktop is debian:1

Starting applications specified in /home/parsa/.vnc/xstartup
Log file is /home/parsa/.vnc/debian:1.log

Then again lets see the log file

tail -f .vnc/debian\:1.log
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)

Now that the error is gone, I connect to vncserver , and these lines appear in the log :

26/09/19 12:18:05 Got connection from client 192.168.1.131
26/09/19 12:18:05 Using protocol version 3.8
26/09/19 12:18:05 Full-control authentication passed by 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 24
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 16
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 22
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 21
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 15
26/09/19 12:18:05 Using zlib encoding for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -314
26/09/19 12:18:05 Enabling full-color cursor updates for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -223
26/09/19 12:18:05 Pixel format for client 192.168.1.131:
26/09/19 12:18:05   8 bpp, depth 6
26/09/19 12:18:05   true colour: max r 3 g 3 b 3, shift r 4 g 2 b 0
26/09/19 12:18:05 Using raw encoding for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 24
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 22
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 21
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 16
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 15
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -314
26/09/19 12:18:05 Enabling full-color cursor updates for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -223
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 24
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 16
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 22
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 21
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding 15
26/09/19 12:18:05 Using zlib encoding for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -314
26/09/19 12:18:05 Enabling full-color cursor updates for client 192.168.1.131
26/09/19 12:18:05 rfbProcessClientNormalMessage: ignoring unknown encoding -223
26/09/19 12:18:05 Pixel format for client 192.168.1.131:
26/09/19 12:18:05   32 bpp, depth 24, little endian
26/09/19 12:18:05   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0
26/09/19 12:18:05   no translation needed

and I see a gray screen in the vnc viewer with a black X cursor :

enter image description here

Could you please help me to fix this problem ?

I have googled this rfbProcessClientNormalMessage: ignoring unknown encoding error a lot but I couldn't find a solution.

here is my ~/.vnc/xstartup by the way :

#!/bin/shxrdb $HOME/.Xresources
xsetroot -solid grey
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
# x-window-manager &
gnome-session &

Thank you.

2

To overcome this I used this ~/.vnc/xstartup from an old solution:

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey &
vncconfig -iconic &

and it works.

  • +1 This worked for me on a fairly fresh install of debian 10 + xfce4 + tightvncserver, thanks! – Jay Marm Aug 12 '20 at 1:03
  • how to use gnome in vncviewer? – ws_ Nov 18 '20 at 9:21
1

Had the same issue when trying to VNC to Debian 10.

Apparently Debian 10 uses Wayland and VNC has some issues with that.

The solution for me was to disable Wayland. To do that, edit /etc/gdm3/daemon.conf and uncomment the line

#WaylandEnable=false

so that instead it reads

WaylandEnable=false

Then restarted the server, started a VNC server and I could connect to it.

  • Thank you for your answer, but unfortunately that does not work... – Parsa Oct 5 '19 at 12:53
  • 1
    The tutorial you linked to was written for Debian 7. So some settings might be outdated. For instance, I noticed it needs some custom xstartup contents, which was not necessary to get it running on Debian 10. What I did to setup vnc on Debian 10 was simply install x11vnc and disable Wayland. Then, to test it, manually started the vnc server from a command line from within a Gnome session on the server (did not work when I started it remotely via ssh). Then connected with a VNC client from another machine and it worked. Might want to try that. – Rupert Augustus Oct 7 '19 at 19:38
1

This question asked about debian with gnome 3. But other answers are mostly about debian with xfce. This issue tooked me a lot of time. Finally this doc saved me.
I use debian 10 with gnome installed , tigervnc as vnc server.

#install vnc servrer
sudo apt install tigervnc-standalone-server 
#start vncserver and allow remote login
vncserver -localhost no :1
#check the port listen stat
netstat -tul | grep 5901

You can use tiger vnc viewer to connect to vnc server with <ip>:1 or <ip>:5901

Remember :
1.log out current user before starting vnc server.
2.You should use ssh tunnel in public network,and forget about -localhost no

#https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-debian-10
ssh -L 5901:127.0.0.1:5901 -C -N -l loginuser your_server_ip

connect to vnc server with localhost:1 or localhost:5901

Something more:
You can see the doc https://help.ubuntu.com/community/VNC/Servers to see how to start TigerVNC vncserver at boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.