2

I'm trying to cross-compile Apache httpd for ARM. Here what I did:

$ sudo apt install libtool
$ git clone https://github.com/apache/httpd.git
$ cd httpd
$ svn co http://svn.apache.org/repos/asf/apr/apr/trunk srclib/apr
$ ./buildconf

The output is:

found apr source: srclib/apr
rebuilding srclib/apr/configure
buildconf: checking installation...
buildconf: python version 3.5.6 (ok)
buildconf: autoconf version 2.69 (ok)
buildconf: libtool not found.
           You need libtool version 1.4 or newer installed
           to build APR from SVN.
./buildconf failed for apr

But libtool is installed:

$ sudo apt install libtool
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libtool is already the newest version (2.4.6-0.1).
1
  • What were your next steps to build it for ARM ? I need to do the same
    – martin-g
    Dec 29, 2019 at 12:01

1 Answer 1

3

/usr/bin/libtool is provided by the package libtool-bin → File search : https://packages.debian.org/search?suite=default&section=all&arch=any&searchon=contents&keywords=usr%2Fbin%2Flibtool

Package search : https://packages.ubuntu.com/search?keywords=libtool-bin&searchon=names

$ sudo apt install libtool-bin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.