I just installed it, and I can't figure out how to do two finger right click by tapping the touchpad. Additionally, I just discovered that I can't tap to click either! Help?

2 Answers 2


Make sure you have sudo apt install xserver-xorg-input-synaptics

In GNOME Tweaks > Keyboard & Mouse, make sure under "Mouse Click Emulation" you select Fingers

Then open Settings > Mouse/Touchpad, and then tick the check box "Tap to Click" and then tap to click and two finger tap to right click is working again

You may need to reboot for this to take effect. enjoy

  • 3
    I was also able to access this menu after installing gnome-tweaks
    – ntjess
    Commented Oct 25, 2020 at 23:57
  • @ntjess gnome-tweaks command shows two toggle items none of which is a cursor option.
    – NoBugs
    Commented Feb 10, 2021 at 6:59
  • Maybe they were preinstalled on my machine... I simply installed the gnome-tweaks package and had access to the same submenus described in this answer
    – ntjess
    Commented Feb 10, 2021 at 15:13
  • That did it. The key was those two settings in two different settings managers. Frustrating, but that worked for me.
    – Cerin
    Commented Sep 9, 2021 at 15:33
  • This works for other desktop environments / window managers and not just GNOME. Since it's actually messing with X config. When I changed from GNOME over to AwesomeWM two finger clicking broke for me, I just had to go back into gnome tweaks, disable the feature then re-enable it.
    – Shardj
    Commented Jun 2, 2022 at 2:26

Since I've come here a few times from the Googles:

  1. Terminal:
sudo apt-get -y install gnome-tweaks
  1. Super

  2. Tweaks (Enter)

  3. Keyboard & Mouse -> Mouse Click Emulation -> Fingers

Underneath it tells you "Click the touchpad with two fingers for right click and three fingers for middle click."

If this is an issue for you be sure to disable the Middle Click Paste radio slider on the same page. :)

  • While explanation of downvotes is not required, it is often helpful. This solved the same problem for me. Commented Sep 20, 2021 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .