-1

I do not have access to the physical server.

I have access to a terminal (via PuTTY) where i can run commands. Is there any command that i can run to determine what hard drives my SunOS 5.11 is using? Is it RAID X? Or on SSD?

I run raidctl -l at the command line, but there is nothing returned. Does this mean that it is not on RAID?

I tried format command, but i got this:

~# format
Searching for disks...done
No disks found!

I did run format as root.

I can't find devfsadm utility. It has most probably been intentionally removed/not installed?. It's not in /usr/sbin and /usr/bin, and there is just a shared object SUNW_fssnap_link.so in this directory /usr/lib/devfsadm/linkmod.

I can't find how to get devfsadm installed. I am not a sysadmin and I do not have a sysadmin at hand. I have been trying randomly pkg install, pkgadd, without success. :/

Update 3: Lambert, thanks. I tried what you mention:

# prtconf -v
System Configuration:  Oracle Corporation  sun4v
Memory size: 261120 Megabytes
System Peripherals (Software Nodes):

prtconf: devinfo facility not available
# cfgadm -alv
-bash: cfgadm: command not found
virtinfo
NAME            CLASS
non-global-zone current
logical-domain  parent
logical-domain  supported
zpool status
  pool: rpool
 state: ONLINE
  scan: none requested
config:

        NAME                     STATE     READ WRITE CKSUM
        rpool                    ONLINE       0     0     0
          c0t5000CCA0164D1C80d0  ONLINE       0     0     0

errors: No known data errors

What can I deduce from that please?

FINAL UPDATE
Great, thanks Lambert(and Andrew)!!.
Finally, found the answer. So the zpool command tells that it's configured as a non-RAID, and the iostat -En tells me the Vendor and Product name, which then tells me that it is a HDD and not a SSD.

Lambert, if you can post the answer, i will accept it.

  • 1
    Did you run format as root? – Andrew Henle Sep 25 '19 at 10:01
  • Try running devfsadm -C, again as root. Try it first as devfsadm -C -v -s to run it in verbose mode and suppress any changes. – Andrew Henle Sep 26 '19 at 22:47
  • 1
    Other possibilities to look at are: /etc/path_to_inst, prtdiag and/or prtconf -v, cfgadm -alv. Perhaps you are logged in onto a non-global zone with limited privileges and without assigned disks. Try virtinfo to see current mode. And Solaris uses ZFS as filesystem, recommended without hardware RAID. Try zpool status to find out how the ZFS pool is configured. – Lambert Sep 27 '19 at 11:21
  • It appears that you are logged into a non-global zone. The zpool status command shows one disk. You can try to use iostat -En to find out the vendor of the disk. An other possibility is to contact the administrator of the global zone (logical domain) and ask the desired information – Lambert Oct 1 '19 at 8:18
  • The zpool is configured as non-RAID, otherwise you would have seen two or more disks under rpool. – Lambert Oct 1 '19 at 8:19
2

If format doesn't report any disks you might be logged into a non-global zone. To verify this you can run virtinfo to see if that's true.

Solaris 11 always uses ZFS as root filesystem. Use zpool status to find out how it's configured.

Using iostat -En it is possible to get the Vendor and Product for a device.

According to the updates in the original post the host used is a non-global zone:

virtinfo
NAME            CLASS
non-global-zone current

and the ZFS pool rpool is contructed of using just one disk:

NAME                     STATE     READ WRITE CKSUM
rpool                    ONLINE       0     0     0
  c0t5000CCA0164D1C80d0  ONLINE       0     0     0

So no software RAID is being used. Please note that it is possible that hardware RAID is in effect but ZFS recommends to use software RAID for self healing capabilities of the pools to be activated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.