2

I have an HP Spectre x360 with two graphics cards (Intel Corporation HD Graphics 620 rev 02 and an NVIDIA Corporation GM108M [GeForce 940MX] rev a2). I installed Debian Testing on it and eventually realized that I needed to use primusrun to let software access the Nvidia graphics card. This worked great for a month or two, and then my Bumblebee setup broke -- possibly during a Debian update or because I removed the wrong package, but I'm not sure.

I've since tried uninstalling and reinstalling different Bumblebee/Nvidia/Primus packages to try to solve the problem, but I keep seeing the following segmentation fault in my Xorg.8.log file when trying to run primusrun glxgears:

[    57.202] (EE) Backtrace:
[    57.205] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55878e22b2c9]
[    57.206] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f784993555f]
[    57.206] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (memcpy+0x1f) [0x7f7849803e4f]
[    57.207] (EE) 3: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x27ff09) [0x7f7848425809]
[    57.207] (EE) 4: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x28006d) [0x7f7848425b2d]
[    57.208] (EE) 5: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv015glcore+0x49ab8) [0x7f7847ed7fd8]
[    57.208] (EE) unw_get_proc_name failed: no unwind info found [-10]
[    57.208] (EE) 6: /usr/lib/nvidia/nvidia/libglxserver_nvidia.so (?+0x0) [0x7f7845e30d32]
[    57.208] (EE) 
[    57.208] (EE) Segmentation fault at address 0x7f7845f2a000
[    57.208] (EE) 
Fatal server error:
[    57.208] (EE) Caught signal 11 (Segmentation fault). Server aborting

I was hoping that this would sort itself out when my Nvidia drivers next upgraded, but they just upgraded to 430.50 but remain broken. Any suggestions on what is broken here or what I should look into would be hugely appreciated!

Here's my entire Xorg.8.log file:

[    57.080] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    57.080] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[    57.080] Current Operating System: Linux diocletian 5.2.0-2-amd64 #1 SMP Debian 5.2.9-2 (2019-08-21) x86_64
[    57.080] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.2.0-2-amd64 root=UUID=1749bf54-f5ee-4ff3-999c-ef940cd0fb27 ro quiet
[    57.080] Build Date: 05 March 2019  08:11:12PM
[    57.080] xorg-server 2:1.20.4-1 (https://www.debian.org/support) 
[    57.080] Current version of pixman: 0.36.0
[    57.080]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    57.080] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    57.080] (==) Log file: "/var/log/Xorg.8.log", Time: Sat Sep 21 16:25:12 2019
[    57.080] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[    57.080] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[    57.080] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    57.080] (==) ServerLayout "Layout0"
[    57.080] (==) No screen section available. Using defaults.
[    57.080] (**) |-->Screen "Default Screen Section" (0)
[    57.080] (**) |   |-->Monitor "<default monitor>"
[    57.080] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[    57.080] (**) |   |-->Device "DiscreteNvidia"
[    57.081] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    57.081] (**) Option "AutoAddDevices" "false"
[    57.081] (**) Option "AutoAddGPU" "false"
[    57.081] (**) Not automatically adding devices
[    57.081] (==) Automatically enabling devices
[    57.081] (**) Not automatically adding GPU devices
[    57.081] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    57.081] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    57.081]    Entry deleted from font path.
[    57.081] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    built-ins
[    57.081] (++) ModulePath set to "/usr/lib/nvidia/nvidia,/usr/lib/xorg/modules"
[    57.081] (==) |-->Input Device "<default pointer>"
[    57.081] (==) |-->Input Device "<default keyboard>"
[    57.081] (==) The core pointer device wasn't specified explicitly in the layout.
    Using the default mouse configuration.
[    57.081] (==) The core keyboard device wasn't specified explicitly in the layout.
    Using the default keyboard configuration.
[    57.081] (II) Loader magic: 0x55878e2b8e20
[    57.081] (II) Module ABI versions:
[    57.081]    X.Org ANSI C Emulation: 0.4
[    57.081]    X.Org Video Driver: 24.0
[    57.081]    X.Org XInput driver : 24.1
[    57.081]    X.Org Server Extension : 10.0
[    57.081] (--) using VT number 2

[    57.081] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    57.082] (II) xfree86: Adding drm device (/dev/dri/card0)
[    57.082] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[    57.085] (--) PCI:*(1@0:0:0) 10de:134d:103c:82c1 rev 162, Mem @ 0xdc000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    57.085] (II) LoadModule: "glx"
[    57.085] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    57.113] (II) Module glx: vendor="X.Org Foundation"
[    57.113]    compiled for 1.20.4, module version = 1.0.0
[    57.113]    ABI class: X.Org Server Extension, version 10.0
[    57.113] (II) LoadModule: "nvidia"
[    57.113] (II) Loading /usr/lib/nvidia/nvidia/nvidia_drv.so
[    57.116] (II) Module nvidia: vendor="NVIDIA Corporation"
[    57.116]    compiled for 1.6.99.901, module version = 1.0.0
[    57.116]    Module class: X.Org Video Driver
[    57.117] (II) LoadModule: "mouse"
[    57.117] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[    57.118] (II) Module mouse: vendor="X.Org Foundation"
[    57.118]    compiled for 1.20.0, module version = 1.9.3
[    57.118]    Module class: X.Org XInput Driver
[    57.118]    ABI class: X.Org XInput driver, version 24.1
[    57.118] (II) LoadModule: "kbd"
[    57.118] (WW) Warning, couldn't open module kbd
[    57.118] (EE) Failed to load module "kbd" (module does not exist, 0)
[    57.119] (II) NVIDIA dlloader X Driver  430.50  Thu Sep  5 22:43:53 CDT 2019
[    57.119] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    57.119] (II) Loading sub module "fb"
[    57.119] (II) LoadModule: "fb"
[    57.120] (II) Loading /usr/lib/xorg/modules/libfb.so
[    57.120] (II) Module fb: vendor="X.Org Foundation"
[    57.120]    compiled for 1.20.4, module version = 1.0.0
[    57.120]    ABI class: X.Org ANSI C Emulation, version 0.4
[    57.120] (II) Loading sub module "wfb"
[    57.120] (II) LoadModule: "wfb"
[    57.120] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    57.121] (II) Module wfb: vendor="X.Org Foundation"
[    57.121]    compiled for 1.20.4, module version = 1.0.0
[    57.121]    ABI class: X.Org ANSI C Emulation, version 0.4
[    57.121] (II) Loading sub module "ramdac"
[    57.121] (II) LoadModule: "ramdac"
[    57.122] (II) Module "ramdac" already built-in
[    57.123] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    57.123] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    57.123] (==) NVIDIA(0): RGB weight 888
[    57.123] (==) NVIDIA(0): Default visual is TrueColor
[    57.123] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    57.123] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[    57.123] (**) NVIDIA(0): Option "UseEDID" "false"
[    57.123] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[    57.123] (**) NVIDIA(0): Enabling 2D acceleration
[    57.123] (**) NVIDIA(0): Ignoring EDIDs
[    57.123] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[    57.123] (**) NVIDIA(0):     mode
[    57.123] (II) Loading sub module "glxserver_nvidia"
[    57.123] (II) LoadModule: "glxserver_nvidia"
[    57.123] (II) Loading /usr/lib/nvidia/nvidia/libglxserver_nvidia.so
[    57.153] (II) Module glxserver_nvidia: vendor="NVIDIA Corporation"
[    57.153]    compiled for 1.6.99.901, module version = 1.0.0
[    57.153]    Module class: X.Org Server Extension
[    57.153] (II) NVIDIA GLX Module  430.50  Thu Sep  5 22:41:46 CDT 2019
[    57.156] (II) NVIDIA(0): NVIDIA GPU GeForce 940MX (GM108-A) at PCI:1:0:0 (GPU-0)
[    57.156] (--) NVIDIA(0): Memory: 2097152 kBytes
[    57.156] (--) NVIDIA(0): VideoBIOS: 82.08.62.00.15
[    57.156] (II) NVIDIA(0): Detected PCI Express Link width: 4X
[    57.156] (II) NVIDIA(0): Validated MetaModes:
[    57.156] (II) NVIDIA(0):     "NULL"
[    57.156] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[    57.156] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    57.156] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[    57.156] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[    57.156] (II) NVIDIA:     access.
[    57.185] (II) NVIDIA(0): Setting mode "NULL"
[    57.189] (==) NVIDIA(0): Disabling shared memory pixmaps
[    57.189] (==) NVIDIA(0): Backing store enabled
[    57.189] (==) NVIDIA(0): Silken mouse enabled
[    57.189] (==) NVIDIA(0): DPMS enabled
[    57.189] (WW) NVIDIA(0): Option "NoLogo" is not used
[    57.189] (II) Loading sub module "dri2"
[    57.189] (II) LoadModule: "dri2"
[    57.189] (II) Module "dri2" already built-in
[    57.189] (II) NVIDIA(0): [DRI2] Setup complete
[    57.189] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[    57.189] (II) Initializing extension Generic Event Extension
[    57.190] (II) Initializing extension SHAPE
[    57.190] (II) Initializing extension MIT-SHM
[    57.190] (II) Initializing extension XInputExtension
[    57.190] (II) Initializing extension XTEST
[    57.190] (II) Initializing extension BIG-REQUESTS
[    57.190] (II) Initializing extension SYNC
[    57.190] (II) Initializing extension XKEYBOARD
[    57.190] (II) Initializing extension XC-MISC
[    57.190] (II) Initializing extension SECURITY
[    57.191] (II) Initializing extension XFIXES
[    57.191] (II) Initializing extension RENDER
[    57.191] (II) Initializing extension RANDR
[    57.191] (II) Initializing extension COMPOSITE
[    57.191] (II) Initializing extension DAMAGE
[    57.191] (II) Initializing extension MIT-SCREEN-SAVER
[    57.191] (II) Initializing extension DOUBLE-BUFFER
[    57.191] (II) Initializing extension RECORD
[    57.191] (II) Initializing extension DPMS
[    57.192] (II) Initializing extension Present
[    57.192] (II) Initializing extension DRI3
[    57.192] (II) Initializing extension X-Resource
[    57.192] (II) Initializing extension XVideo
[    57.192] (II) Initializing extension XVideo-MotionCompensation
[    57.192] (II) Initializing extension SELinux
[    57.192] (II) SELinux: Disabled on system
[    57.192] (II) Initializing extension GLX
[    57.192] (II) Initializing extension GLX
[    57.192] (II) Indirect GLX disabled.
[    57.192] (II) GLX: Another vendor is already registered for screen 0
[    57.192] (II) Initializing extension XFree86-VidModeExtension
[    57.192] (II) Initializing extension XFree86-DGA
[    57.193] (II) Initializing extension XFree86-DRI
[    57.193] (II) Initializing extension DRI2
[    57.193] (II) Initializing extension NV-GLX
[    57.193] (II) Initializing extension NV-CONTROL
[    57.202] (EE) 
[    57.202] (EE) Backtrace:
[    57.205] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x139) [0x55878e22b2c9]
[    57.206] (EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x50) [0x7f784993555f]
[    57.206] (EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (memcpy+0x1f) [0x7f7849803e4f]
[    57.207] (EE) 3: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x27ff09) [0x7f7848425809]
[    57.207] (EE) 4: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv043glcore+0x28006d) [0x7f7848425b2d]
[    57.208] (EE) 5: /usr/lib/x86_64-linux-gnu/libnvidia-glcore.so.430.50 (_nv015glcore+0x49ab8) [0x7f7847ed7fd8]
[    57.208] (EE) unw_get_proc_name failed: no unwind info found [-10]
[    57.208] (EE) 6: /usr/lib/nvidia/nvidia/libglxserver_nvidia.so (?+0x0) [0x7f7845e30d32]
[    57.208] (EE) 
[    57.208] (EE) Segmentation fault at address 0x7f7845f2a000
[    57.208] (EE) 
Fatal server error:
[    57.208] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    57.208] (EE) 
[    57.208] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    57.208] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[    57.208] (EE) 
[    57.210] (EE) Server terminated with error (1). Closing log file.
2

Yup, it was related to debian #939839. As per the advice on debian #939401, I installed the Debian 390x legacy drivers:

sudo apt install nvidia-legacy-390xx-driver

And then reconfigured my GLX setup to use the Nvidia 390x drivers rather than the Nvidia 430 drivers:

sudo update-glx --config nvidia

And that fixed everything. Hopefully, eventually the 430 drivers will be fixed and I'll be able to switch back to them.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.