3

I'm trying to disable avahi-daemon. I tried to modify the file /etc/default/avahi-daemon, setting the AVAHI_DAEMON_DETECT_LOCAL=0 instead of 1, but when I connect to a network it starts anyway; is there no way to stop it?

I am trying to stop it because every time I connect to a network it and dhclient starts it gives my NIC another address so I cannot access the network. I'm on a Debian machine.

1
  • The avahi dae/etc/resolvconf/update-libc.d/avahi-daemonmon can be started by /etc/network/if-up.d/avahi-daemon and ``, but this too is disabled if you have AVAHI_DAEMON_DETECT_LOCAL=0 in /etc/default/avahi-daemon. What version of the avahi-daemon package do you have? What is the full contents of /etc/default/avahi-daemon? Commented Jan 5, 2011 at 19:24

2 Answers 2

4
sudo update-rc.d -f avahi-daemon remove
3
  • hi, and if i want to enable it again?
    – dany
    Commented Jan 5, 2011 at 14:46
  • sudo update-rc.d avahi-daemon defaults
    – trojanfoe
    Commented Jan 5, 2011 at 14:48
  • cheers! I m going to try it
    – dany
    Commented Jan 5, 2011 at 14:53
0

You can use rcconf to disable it starting it from boot or you can manually remove it from autostartup with;

update-rc.d -f avahi-daemon remove

Only root can do this so use sudo if you are not root.

3
  • so you are saying that the file /etc/default/avhi-daemon is useless? in debian there is no rc.conf file :(
    – dany
    Commented Jan 5, 2011 at 14:46
  • rcconf is a program :) And the default file is for changing the behaviour of avahi-daemon not to stop it.
    – ismail
    Commented Jan 5, 2011 at 14:51
  • ah ok I got it! I don't have that program so I have to change the behavior.. Cheers! I m going to try it
    – dany
    Commented Jan 5, 2011 at 14:53

You must log in to answer this question.