1

My 18.3 Cinnamon install ran flawlessly for two years until now. I'm running it on i7-7700 with 32GB of RAM. I have an application, Ultimaker_Cura_4.1.appimage, that sits on my desktop and runs fine, but I prefer to have things in my menu or panel. I decided to put a link to the .appimage in my Home folder and make what I believe to be called a "launcher" in the menu or panel -- either place is fine. I went online and found a process to do what I thought I wanted and did the following:

Right-clicked on Menu

Clicked on Configure

Open the Menu Editor

Created a new file (launcher?)

Entered a name in the first field

Entered a path to the application in the second field (Ultimaker_Cura_4.1)

Clicked out

I then couldn't see the new item on the panel or menu so I then tried to go back into the menu editor, but after right-clicking on the Menu and clicking on Configure, the Menu Editor no longer responded to a mouse click. Everything seemed OK other than that, so I restarted cinnamon (alt-F2, R, enter). When the menu came back, all my applications were missing. Now Cinnamon crashes immediately after I log in and refuses to start. In fallback mode everything seems OK, but I'd like to get all my menu-applications back. Clearly the last thing I did is crashing it somehow. Is there a way to undo my most recent menu/panel changes via the command line or a text editor?

Thanks in advance, SM

4
  • Your new launcher should be located in $HOME/.local/share/applications. I would delete the offending entry and try again. – ajgringo619 Sep 20 '19 at 17:44
  • Deleted offending file, but can only see applications in Fallback mode. If I right-click on Configure, clicking on Menu>Open_the_Menu_Editor does nothing. Left clicking on Menu opens file search bar (can't see applications) & shows a button called "All Applications" & clicking does nothing as well. Tried LookingGlass/Melange and did a settings reset to default, but all that gave me was "Quit", "Logout" and "Lock Screen" button on menu. BTW, all my applications and custom launchers are still in the applications folder you mentioned above and fallback menu runs well. – SiggyMarvin Sep 20 '19 at 19:42
  • Try removing the menu from the panel, then adding it back. If that doesn't work, try resetting your menu by running this: gsettings reset-recursively org.cinnamon – ajgringo619 Sep 20 '19 at 22:11
  • Did both twice and no change and still can't "Open the Menu Editor". It's button acknowledges my click by changing from grey to green and then nothing. Doing the above seemed promising, but when it came back it was exactly the same. It runs great otherwise, it just won't show or launch applications. I'm can only get to my browser by either Fallback mode or typing Opera in Terminal. Thanks again so much for your help. – SiggyMarvin Sep 21 '19 at 0:30
0

Delete ~/.config/menus then Logout/Login

Source: All menu & panel applications are missing in Mint 18.3 Cinnamon after adding a launcher - Linux Mint Forums.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.