1

I'm running archlinux and have an ext3 10Tb internal harddrive that is failing to mount on boot through the fstab entry. If I use mount /dev/sdc1 /media, the mount succeeds however attempting to do a mount -a gives the result

mount: /media: wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error.

I used df -Th to confirm the filesystem and got

 /dev/sdc1      ext3      9.1T  3.8T  4.9T  44% /media

I ran e2fsck to check the disk and got this

sudo e2fsck -f /dev/sdc1
e2fsck 1.45.3 (14-Jul-2019)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sdc1: 30662/305201152 files (50.0% non-contiguous), 1020563007/2441608704 blocks

Which as far as I understand is all pass.

The fstab entry at the moment is

UUID=239630fb-affe-4810-a3a1-6d7c7958af86   /media      ext3        permissions,defaults    0 0

#/dev/sdc1                  /media      autofs      permissions,defaults    0 0

I've tried ext3, auto, and autofs as the file system for both entries but neither seems to help.

  • 1
    Add your /etc/fstab to your question. – ajgringo619 Sep 20 '19 at 17:10
  • 1
    Are you sure about the UUID in /etc/fstab? Try changing that line to read /dev/sdc1 /media etx3 permissions,defaults 0 0. – ajgringo619 Sep 20 '19 at 17:19
  • ext3, not etx3 - sorry! :( – ajgringo619 Sep 20 '19 at 17:34
  • 1
    I've never come across permissions as a valid option for extN filesystems, and a quick look through the man pages doesn't offer me anything exciting. Are you sure it's valid? – roaima Sep 20 '19 at 17:46
  • Can you mount the filesystem using just mount /media after boot? – Jonas Berlin Sep 20 '19 at 17:50
2

The permissions option in your /etc/fstab isn't valid for an ext3 filesystem

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.