0

I run Xfce. When I attach an external monitor to my laptop and enable it as a secondary monitor, all my open windows are moved to it from a primary display.

How to configure Xfce so that open windows stay at primary display?

This is the detailed sequence of steps I perform:

  1. Plug in external monitor
  2. Open Xfce Display Manager
  3. Choose "Extend to the right":

Xfce Display Manager - Extend to the right

  1. Click "Advanced"
  2. Rearrange displays (I put an external secondary "Lenovo" monitor above my primary "Chimei" laptop display)
  3. Mark my "Chimei" laptop display as "Primary display":

Xfce Display Manager - Advanced

  1. Click "Apply"
  2. I would expect that my open windows stay on the primary display, but in fact Xfce moves them to the secondary display.

Software versions:

  • Ubuntu 16.04.6 LTS
  • xfce4-display-settings 4.12.0 (Xfce 4.12)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.