0

Am new to IT and I am having troubles with my Oracle Linux 8 installed into Vmware Esxi 6.5. I can't update or install using either of yum or dnf commands. I get the following error:

# yum update
Last metadata expiration check: 0:07:13 ago on Thu 19 Sep 2019 12:15:03 PM JST.
Error: 
 Problem 1: package sos-3.7-6.0.1.el7_7.noarch requires /usr/bin/python, but none of the providers can be installed
  - cannot install the best update candidate for package sos-3.6-10.0.1.el8_0.3.noarch
  - package python-2.7.5-69.0.1.el7_5.x86_64 is excluded
  - package python-2.7.5-77.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-76.0.1.el7.x86_64 is excluded
  - package python-2.7.5-79.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-68.0.1.el7.x86_64 is excluded
  - package python-2.7.5-80.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-86.0.1.el7.x86_64 is excluded
 Problem 2: package gnome-shell-3.28.3-11.el7.x86_64 requires python(x86-64), but none of the providers can be installed
  - cannot install the best update candidate for package gnome-shell-3.28.3-10.el8.x86_64
  - package python-2.7.5-69.0.1.el7_5.x86_64 is excluded
  - package python-2.7.5-77.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-76.0.1.el7.x86_64 is excluded
  - package python-2.7.5-79.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-68.0.1.el7.x86_64 is excluded
  - package python-2.7.5-80.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-86.0.1.el7.x86_64 is excluded
 Problem 3: package gdk-pixbuf2-modules-2.36.12-2.el8.x86_64 requires gdk-pixbuf2(x86-64) = 2.36.12-2.el8, but none of the providers can be installed
  - cannot install both gdk-pixbuf2-2.36.12-3.el7.x86_64 and gdk-pixbuf2-2.36.12-2.el8.x86_64
  - cannot install the best update candidate for package gdk-pixbuf2-modules-2.36.12-2.el8.x86_64
  - cannot install the best update candidate for package gdk-pixbuf2-2.36.12-2.el8.x86_64
 Problem 4: package gnome-session-wayland-session-3.28.1-6.el8.x86_64 requires gnome-session(x86-64) = 3.28.1-6.el8, but none of the providers can be installed
  - cannot install both gnome-session-3.28.1-7.el7.x86_64 and gnome-session-3.28.1-6.el8.x86_64
  - cannot install the best update candidate for package gnome-session-wayland-session-3.28.1-6.el8.x86_64
  - cannot install the best update candidate for package gnome-session-3.28.1-6.el8.x86_64
 Problem 5: cannot install both libbluray-0.2.3-5.el7.x86_64 and libbluray-1.0.2-3.el8.x86_64
  - package gvfs-1.36.2-3.el7.x86_64 requires libbluray.so.1()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libbluray-1.0.2-3.el8.x86_64
  - cannot install the best update candidate for package gvfs-1.36.2-2.el8_0.1.x86_64
 Problem 6: cannot install both libgcrypt-1.5.3-14.el7.x86_64 and libgcrypt-1.8.3-2.el8.x86_64
  - package gvfs-afp-1.36.2-3.el7.x86_64 requires libgcrypt.so.11()(64bit), but none of the providers can be installed
  - package gvfs-afp-1.36.2-3.el7.x86_64 requires libgcrypt.so.11(GCRYPT_1.2)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libgcrypt-1.8.3-2.el8.x86_64
  - cannot install the best update candidate for package gvfs-afp-1.36.2-2.el8_0.1.x86_64
 Problem 7: cannot install both libpng-2:1.5.13-7.el7_2.x86_64 and libpng-2:1.6.34-5.el8.x86_64
  - package cairo-1.15.12-4.el7.x86_64 requires libpng15.so.15()(64bit), but none of the providers can be installed
  - package cairo-1.15.12-4.el7.x86_64 requires libpng15.so.15(PNG15_0)(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package libpng-2:1.6.34-5.el8.x86_64
  - cannot install the best update candidate for package cairo-1.15.12-3.el8.x86_64
 Problem 8: package ndctl-65-1.0.1.el7.x86_64 requires libjson-c.so.2()(64bit), but none of the providers can be installed
  - cannot install both json-c-0.11-4.el7_0.x86_64 and json-c-0.13.1-0.2.el8.x86_64
  - cannot install the best update candidate for package ndctl-62-2.el8.x86_64
  - cannot install the best update candidate for package json-c-0.13.1-0.2.el8.x86_64
 Problem 9: package python3-libs-3.6.8-10.0.1.el7.x86_64 requires libtirpc.so.1()(64bit), but none of the providers can be installed
  - cannot install both libtirpc-0.2.4-0.16.el7.x86_64 and libtirpc-1.1.4-3.el8.x86_64
  - cannot install both libtirpc-0.2.4-0.15.el7.x86_64 and libtirpc-1.1.4-3.el8.x86_64
  - cannot install both libtirpc-0.2.4-0.10.el7.x86_64 and libtirpc-1.1.4-3.el8.x86_64
  - cannot install the best update candidate for package python3-libs-3.6.8-4.0.1.el8_0.x86_64
  - cannot install the best update candidate for package libtirpc-1.1.4-3.el8.x86_64
 Problem 10: cannot install both tracker-1.10.5-6.el7.x86_64 and tracker-2.1.5-1.el8.x86_64
  - installed package tracker-2.1.5-1.el8.x86_64 obsoletes tracker < 1.99.2 provided by tracker-1.10.5-6.el7.x86_64
  - package gnome-boxes-3.28.5-4.el7.x86_64 requires libtracker-sparql-1.0.so.0()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package tracker-2.1.5-1.el8.x86_64
  - cannot install the best update candidate for package gnome-boxes-3.28.5-3.el8.x86_64
 Problem 11: package tuned-2.11.0-5.0.2.el7_7.1.noarch requires python-linux-procfs, but none of the providers can be installed
  - package python-linux-procfs-0.4.9-4.el7.noarch requires /usr/bin/python, but none of the providers can be installed
  - package python-linux-procfs-0.4.9-3.el7.noarch requires /usr/bin/python, but none of the providers can be installed
  - package python-linux-procfs-0.4.11-4.el7.noarch requires /usr/bin/python, but none of the providers can be installed
  - cannot install the best update candidate for package tuned-2.10.0-15.0.7.el8.noarch
  - package python-2.7.5-69.0.1.el7_5.x86_64 is excluded
  - package python-2.7.5-77.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-76.0.1.el7.x86_64 is excluded
  - package python-2.7.5-79.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-68.0.1.el7.x86_64 is excluded
  - package python-2.7.5-80.0.1.el7_6.x86_64 is excluded
  - package python-2.7.5-86.0.1.el7.x86_64 is excluded
 Problem 12: alsa-lib-1.1.6-3.el8.i686 has inferior architecture
  - package alsa-ucm-1.1.6-3.el8.x86_64 requires alsa-lib = 1.1.6-3.el8, but none of the providers can be installed
  - cannot install both alsa-lib-1.1.8-1.el7.x86_64 and alsa-lib-1.1.6-3.el8.x86_64
  - cannot install the best update candidate for package alsa-ucm-1.1.6-3.el8.x86_64
  - cannot install the best update candidate for package alsa-lib-1.1.6-3.el8.x86_64
 Problem 13: package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1(CDIO_CDDA_1)(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit), but none of the providers can be installed
  - cannot install both libcdio-paranoia-10.2+0.90-11.el7.x86_64 and libcdio-paranoia-10.2+0.94+2-3.el8.x86_64
  - package gvfs-afc-1.36.2-3.el7.x86_64 requires gvfs(x86-64) = 1.36.2-3.el7, but none of the providers can be installed
  - cannot install the best update candidate for package libcdio-paranoia-10.2+0.94+2-3.el8.x86_64
  - cannot install the best update candidate for package gvfs-afc-1.36.2-2.el8_0.1.x86_64
 Problem 14: package gvfs-1.36.2-3.el7.x86_64 requires libcdio.so.15()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio.so.15(CDIO_15)(64bit), but none of the providers can be installed
  - cannot install both libcdio-0.92-3.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - cannot install both libcdio-0.92-1.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - package gvfs-archive-1.36.2-3.el7.x86_64 requires gvfs(x86-64) = 1.36.2-3.el7, but none of the providers can be installed
  - cannot install the best update candidate for package libcdio-2.0.0-2.el8.x86_64
  - cannot install the best update candidate for package gvfs-archive-1.36.2-2.el8_0.1.x86_64
 Problem 15: package glusterfs-cli-3.12.2-47.2.el7.x86_64 requires libreadline.so.6()(64bit), but none of the providers can be installed
  - cannot install both readline-6.2-11.el7.x86_64 and readline-7.0-10.el8.x86_64
  - cannot install both readline-6.2-10.el7.x86_64 and readline-7.0-10.el8.x86_64
  - cannot install the best update candidate for package readline-7.0-10.el8.x86_64
  - cannot install the best update candidate for package glusterfs-cli-3.12.2-40.2.el8.x86_64
 Problem 16: package xorg-x11-drv-vesa-2.4.0-3.el8.x86_64 requires xorg-x11-server-wrapper, but none of the providers can be installed
  - cannot install both xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 and xorg-x11-server-Xorg-1.20.3-5.2.el8_0.x86_64
  - cannot install both xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 and xorg-x11-server-Xorg-1.20.3-5.el8.x86_64
  - cannot install the best update candidate for package xorg-x11-server-Xorg-1.20.3-5.2.el8_0.x86_64
  - cannot install the best update candidate for package xorg-x11-drv-vesa-2.4.0-3.el8.x86_64
 Problem 17: package webkit2gtk3-plugin-process-gtk2-2.22.6-1.el8.x86_64 requires libpng16.so.16()(64bit), but none of the providers can be installed
  - package webkit2gtk3-plugin-process-gtk2-2.22.6-1.el8.x86_64 requires libpng16.so.16(PNG16_0)(64bit), but none of the providers can be installed
  - cannot install both libpng-2:1.5.13-7.el7_2.x86_64 and libpng-2:1.6.34-5.el8.x86_64
  - package cairo-gobject-1.15.12-4.el7.x86_64 requires libpng15.so.15()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package webkit2gtk3-plugin-process-gtk2-2.22.6-1.el8.x86_64
  - cannot install the best update candidate for package cairo-gobject-1.15.12-3.el8.x86_64
 Problem 18: package python3-libstoragemgmt-clibs-1.6.2-9.el8.x86_64 requires libstoragemgmt = 1.6.2-9.el8, but none of the providers can be installed
  - libstoragemgmt-1.6.2-9.el8.i686 has inferior architecture
  - cannot install both libstoragemgmt-1.7.3-3.0.1.el7.x86_64 and libstoragemgmt-1.6.2-9.el8.x86_64
  - cannot install the best update candidate for package python3-libstoragemgmt-clibs-1.6.2-9.el8.x86_64
  - cannot install the best update candidate for package libstoragemgmt-1.6.2-9.el8.x86_64
 Problem 19: package gdm-1:3.28.3-20.el8.x86_64 requires gnome-session-wayland-session, but none of the providers can be installed
  - package gnome-session-wayland-session-3.28.1-6.el8.x86_64 requires gnome-session(x86-64) = 3.28.1-6.el8, but none of the providers can be installed
  - package gnome-session-wayland-session-3.28.1-6.el7.x86_64 requires gnome-session(x86-64) = 3.28.1-6.el7, but none of the providers can be installed
  - cannot install both gnome-session-3.28.1-7.el7.x86_64 and gnome-session-3.28.1-6.el8.x86_64
  - cannot install both gnome-session-3.28.1-6.el7.x86_64 and gnome-session-3.28.1-7.el7.x86_64
  - package gnome-session-xsession-3.28.1-7.el7.x86_64 requires gnome-session(x86-64) = 3.28.1-7.el7, but none of the providers can be installed
  - cannot install the best update candidate for package gnome-session-xsession-3.28.1-6.el8.x86_64
  - cannot install the best update candidate for package gdm-1:3.28.3-20.el8.x86_64
 Problem 20: problem with installed package libcdio-paranoia-10.2+0.94+2-3.el8.x86_64
  - cannot install both libcdio-paranoia-10.2+0.90-11.el7.x86_64 and libcdio-paranoia-10.2+0.94+2-3.el8.x86_64
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1(CDIO_CDDA_1)(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit), but none of the providers can be installed
  - package gvfs-fuse-1.36.2-3.el7.x86_64 requires gvfs(x86-64) = 1.36.2-3.el7, but none of the providers can be installed
  - cannot install the best update candidate for package gvfs-fuse-1.36.2-2.el8_0.1.x86_64
 Problem 21: problem with installed package libbluray-1.0.2-3.el8.x86_64
  - cannot install both libbluray-0.2.3-5.el7.x86_64 and libbluray-1.0.2-3.el8.x86_64
  - package gvfs-1.36.2-3.el7.x86_64 requires libbluray.so.1()(64bit), but none of the providers can be installed
  - package gvfs-goa-1.36.2-3.el7.x86_64 requires gvfs(x86-64) = 1.36.2-3.el7, but none of the providers can be installed
  - cannot install the best update candidate for package gvfs-goa-1.36.2-2.el8_0.1.x86_64
 Problem 22: package python3-libdnf-0.22.5-5.0.2.el8.x86_64 requires libjson-c.so.4()(64bit), but none of the providers can be installed
  - cannot install both json-c-0.11-4.el7_0.x86_64 and json-c-0.13.1-0.2.el8.x86_64
  - package ndctl-65-1.0.1.el7.x86_64 requires libjson-c.so.2()(64bit), but none of the providers can be installed
  - package libblockdev-nvdimm-2.19-7.el8.x86_64 requires ndctl, but none of the providers can be installed
  - package ndctl-62-2.el8.x86_64 requires daxctl-libs(x86-64) = 62-2.el8, but none of the providers can be installed
  - package ndctl-60.1-6.el7.x86_64 requires daxctl-libs(x86-64) = 60.1-6.el7, but none of the providers can be installed
  - package ndctl-64.1-2.el7.x86_64 requires daxctl-libs(x86-64) = 64.1-2.el7, but none of the providers can be installed
  - package ndctl-62-1.el7.x86_64 requires daxctl-libs(x86-64) = 62-1.el7, but none of the providers can be installed
  - package ndctl-58.2-3.el7.x86_64 requires daxctl-libs(x86-64) = 58.2-3.el7, but none of the providers can be installed
  - cannot install both daxctl-libs-65-1.0.1.el7.x86_64 and daxctl-libs-62-2.el8.x86_64
  - cannot install both daxctl-libs-60.1-6.el7.x86_64 and daxctl-libs-65-1.0.1.el7.x86_64
  - cannot install both daxctl-libs-64.1-2.el7.x86_64 and daxctl-libs-65-1.0.1.el7.x86_64
  - cannot install both daxctl-libs-62-1.el7.x86_64 and daxctl-libs-65-1.0.1.el7.x86_64
  - cannot install both daxctl-libs-58.2-3.el7.x86_64 and daxctl-libs-65-1.0.1.el7.x86_64
  - cannot install the best update candidate for package python3-libdnf-0.22.5-5.0.2.el8.x86_64
  - cannot install the best update candidate for package libblockdev-nvdimm-2.19-7.el8.x86_64
  - cannot install the best update candidate for package daxctl-libs-62-2.el8.x86_64
 Problem 23: package yelp-2:3.28.1-3.el8.x86_64 requires libgcrypt.so.20()(64bit), but none of the providers can be installed
  - cannot install both libgcrypt-1.5.3-14.el7.x86_64 and libgcrypt-1.8.3-2.el8.x86_64
  - package gvfs-afp-1.36.2-3.el7.x86_64 requires libgcrypt.so.11()(64bit), but none of the providers can be installed
  - package gvfs-afp-1.36.2-3.el7.x86_64 requires libgcrypt.so.11(GCRYPT_1.2)(64bit), but none of the providers can be installed
  - problem with installed package gvfs-afp-1.36.2-2.el8_0.1.x86_64
  - package gvfs-afp-1.36.2-2.el8_0.1.x86_64 requires gvfs-client(x86-64) = 1.36.2-2.el8_0.1, but none of the providers can be installed
  - cannot install both gvfs-client-1.36.2-3.el7.x86_64 and gvfs-client-1.36.2-2.el8_0.1.x86_64
  - cannot install the best update candidate for package yelp-2:3.28.1-3.el8.x86_64
  - cannot install the best update candidate for package gvfs-client-1.36.2-2.el8_0.1.x86_64
 Problem 24: package python3-hawkey-0.22.5-5.0.2.el8.x86_64 requires libjson-c.so.4()(64bit), but none of the providers can be installed
  - cannot install both json-c-0.11-4.el7_0.x86_64 and json-c-0.13.1-0.2.el8.x86_64
  - package ndctl-65-1.0.1.el7.x86_64 requires libjson-c.so.2()(64bit), but none of the providers can be installed
  - problem with installed package ndctl-62-2.el8.x86_64
  - package ndctl-62-2.el8.x86_64 requires ndctl-libs(x86-64) = 62-2.el8, but none of the providers can be installed
  - package ndctl-64.1-2.el7.x86_64 requires ndctl-libs(x86-64) = 64.1-2.el7, but none of the providers can be installed
  - cannot install both ndctl-libs-65-1.0.1.el7.x86_64 and ndctl-libs-62-2.el8.x86_64
  - cannot install both ndctl-libs-64.1-2.el7.x86_64 and ndctl-libs-65-1.0.1.el7.x86_64
  - cannot install the best update candidate for package python3-hawkey-0.22.5-5.0.2.el8.x86_64
  - cannot install the best update candidate for package ndctl-libs-62-2.el8.x86_64
 Problem 25: package libcdio-paranoia-10.2+0.90-11.el7.x86_64 requires libcdio.so.15()(64bit), but none of the providers can be installed
  - package libcdio-paranoia-10.2+0.90-11.el7.x86_64 requires libcdio.so.15(CDIO_15)(64bit), but none of the providers can be installed
  - cannot install both libcdio-0.92-3.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - cannot install both libcdio-0.92-1.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - package gstreamer1-plugins-ugly-free-1.14.0-2.el8.x86_64 requires libcdio.so.18()(64bit), but none of the providers can be installed
  - package gstreamer1-plugins-ugly-free-1.14.0-2.el8.x86_64 requires libcdio.so.18(CDIO_18)(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1(CDIO_CDDA_1)(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit), but none of the providers can be installed
  - package gvfs-gphoto2-1.36.2-3.el7.x86_64 requires gvfs(x86-64) = 1.36.2-3.el7, but none of the providers can be installed
  - cannot install the best update candidate for package gvfs-gphoto2-1.36.2-2.el8_0.1.x86_64
  - cannot install the best update candidate for package gstreamer1-plugins-ugly-free-1.14.0-2.el8.x86_64
 Problem 26: package libcdio-paranoia-10.2+0.90-11.el7.x86_64 requires libcdio.so.15()(64bit), but none of the providers can be installed
  - package libcdio-paranoia-10.2+0.90-11.el7.x86_64 requires libcdio.so.15(CDIO_15)(64bit), but none of the providers can be installed
  - cannot install both libcdio-0.92-3.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - cannot install both libcdio-0.92-1.el7.x86_64 and libcdio-2.0.0-2.el8.x86_64
  - problem with installed package libcdio-2.0.0-2.el8.x86_64
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1()(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_cdda.so.1(CDIO_CDDA_1)(64bit), but none of the providers can be installed
  - package gvfs-1.36.2-3.el7.x86_64 requires libcdio_paranoia.so.1()(64bit), but none of the providers can be installed
1

Note that the installed packages have the .el8 suffix, but many of the packages the tool is complaining about have the .el7 suffix.

I see two possibilities. Either this system has been misconfigured to connect to a OEL7 repository instead of a OEL8 one, or the repository server has a mix of OEL7 and OEL8 packages, which means the repository has been corrupted.

You should first run rpm -qa |grep '\.el7'. If you do have any OEL7 packages currently installed, you may have a problem: a mix-up in repository configuration has caused parts of your system to be downgraded to OEL7 levels. Backup your data first. If there are no OEL7 packages reported, a sigh of relief is appropriate.

Then check any files in /etc/yum.repos.d and remove or disable any repositories referring to OEL7 content, and then run yum clean all, then yum check-update to see what it will offer to do now. If it turns out that a package repository that is supposed to have OEL8 content actually has OEL7 packages mixed in, alert the administrator of that package repository server to fix their corrupted repository, or else you may eventually have more partially downgraded servers to fix instead of just one.

If there was any OEL7 packages installed, the package manager might now be suggesting to replace them with OEL8 equivalents: that would be a good thing. (Basically I'm hoping that anything that may have got downgraded automatically would also get upgraded just as easily.)

If it still complains about something, you may have a OEL7 package which has no direct replacement in OEL8 and which is "anchoring" other OEL7 packages through dependencies. This might be the result of trying to use packages from the EPEL repository intended for RHEL/OEL release 7.x in OEL release 8. You may then have to locate and manually update or temporarily uninstall the "anchor" packages so that all the others can be un-downgraded back to OEL8 levels.

If there seems to be a large number of OEL7 packages installed, you might want to consider the nuclear option of backing up your data and reinstalling from scratch. It might be easier and certainly faster than spending time to untangle the mess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.