0

I have a CentOS 7.6 server, and I have Samba 4.8.3 authenticates by both AD and NIS.

MY AD domain is Windows 2008 and has services for UNIX running on it and all the UID's and GID match between the UNIX NIS environment and AD.

Now on this system I can't figure out how to get the GID/UIDs to match this particular system:

[root@nash ~]# id reeder
uid=2351(reeder) gid=15000(staff) groups=15000(staff),1405(dos105),1362(dex105),1393(dos104),1408(eidos),15020(epousr),1369(pt101),1370(wt101),243(r949),1361(mg_bkey),1366(dos101),1396(ky102),1384(ky101)
[root@nash ~]# id AD\\reeder
uid=16777227(AD\reeder) gid=16777226(AD\domain users) groups=16777226(AD\domain users),16777228(AD\pm),16777229(AD\employees),16777310(AD\dos105),16777232(AD\tm),16777305(AD\epousr),16777306(AD\r949),16777240(AD\projectemployees),16777257(AD\engineers),16777307(AD\staff),16777260(AD\managers),16777261(AD\pceplus),16777264(AD\lboro),16777311(AD\dos104),16777312(AD\eidos),16777313(AD\dex105),16777308(AD\ky102),16777271(AD\allstaff),16777309(AD\ky101),16777272(AD\ras nos users),16777273(AD\bugs),16777221(AD\ras nos users),16777224(AD\engineers),16777327(BUILTIN\users)
[root@nash ~]#

My smb.conf file:

[global]
        workgroup = AD
        realm = AD.ACME.COM
        server string = Samba file and print server
        security = ads
        log level = 9
        log file = /var/log/samba/%m.log
        max log size = 60
        idmap config * : range = 1000-63554431
        idmap config * : backend = tdb
        hosts allow =  10.1.254., 10.1.1., 127., 10.1.253.
        passdb backend = tdbsam
        local master = yes
        os level = 33
        preferred master = auto
        wins support = no
[projects]
        comment = Project area
        path = /data/projects
        read only = No
        guest ok = yes
        browseable = yes
        writeable = yes

I have tried using wbinfo to remap but get this:

[root@nash ~]#  wbinfo --set-gid-mapping=1402,S-1-5-21-1121081192-1597767529-1210198002-16742
failed to call wbcSetGidMapping: WBC_ERR_NOT_IMPLEMENTED
Could not create or modify gid to sid mapping
[root@nash ~]#

I have tried pdbedit but get:

my_netbios_names[0]="NASH"
Attempting to find a passdb backend to match tdbsam (tdbsam)
No builtin backend found, trying to load plugin
load_module_absolute_path: Probing module '/usr/lib64/samba/pdb/tdbsam.so'
load_module_absolute_path: Module '/usr/lib64/samba/pdb/tdbsam.so' loaded
Attempting to register passdb backend tdbsam
Successfully added passdb backend 'tdbsam'
Found pdb backend tdbsam
pdb backend tdbsam has a valid init
tdbsam_open: successfully opened /var/lib/samba/private/passdb.tdb
pdb_getsampwnam (TDB): error fetching database.
 Key: USER_list
Username not found!

Not sure where where I screwed up, but I have. Any help is appreciated.

EDIT:: If i do a "net ads sid " I get all the correct info for users and GID's

net ads sid -U administrator S-1-5-21-1121081192-1597767529-1210198002-16804

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.