0

I use systemd-boot as boot manager.
I have the menu with many entries but 90% of time I choose entry #3.

Is there a way to hide the menu as default? In this way when I want to boot #3, it skips timeout and menu is not shown.
While if I want to choose anything else, keep pressing a key i.e. shift to show the menu?

1 Answer 1

1

According to the manual of loader.conf you can disable the timeout and it does what you want:

timeout

How long the boot menu should be shown before the default entry is booted, in seconds. This may be changed in the boot menu itself and will be stored as an EFI variable in that case, overriding this option.

If the timeout is disabled, the default entry will be booted immediately. The menu can be shown by pressing and holding a key before systemd-boot is launched.

In the menu you can change the timeout value with these keys (see systemd-boot):

  • +, t Increase the timeout before default entry is booted

  • -, T Decrease the timeout

and also

  • d Make selected entry the default

(I don't know if you can disable the timeout with these key combinations. Maybe.)

3
  • I tried both timeout 0 and remove the timeout line but I always get a menu with 3 seconds timeout...
    – mattia.b89
    Sep 18, 2019 at 14:01
  • Can you change the timeout to zero with the - key in the menu? The value stored as EFI variable should override loader.conf.
    – Freddy
    Sep 18, 2019 at 14:05
  • Yes, I changed timeout directly from the menu but this behaviour makes loader.conf useless; Is there a way to ignore those EFI variable?
    – mattia.b89
    Sep 20, 2019 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .