1

I have a .desktop file in /usr/share/applications with the entry:

[Desktop Entry]
Icon=my-app
...

I have placed my-app.png into /usr/share/icons/hicolor/32x32/apps.

The icon displays just fine for its entry in the MATE Application menu if I explicitly point it to the icon location:

Icon=/usr/share/icons/hicolor/32x32/apps/my-app.png

But it doesn't work if I use the basename:

Icon=my-app

Why is it failing with just the basename? This seems to be how other applications do it.

I am referencing the specifications from freedesktop.org. My distro is Fedora 30.

This is testing for an RPM package so I am not looking for answers that direct me to place it anywhere in my home folder.

2 Answers 2

3

I had the same problem and what worked for me was to update the cache of the hicolor theme: /usr/share/icons/hicolor/icon-theme.cache. You do this with the following command:

sudo gtk-update-icon-cache -f /usr/share/icons/hicolor/

The -f option means it will overwrite the current cache, even if it is up to date.

This worked for me; I'm using Ubuntu 18.04 and GNOME. Maybe there is something similar for MATE.

0

Use a custom url for you're icon.

Icon=/some/dir/icon.png

Also chech the size of the icon. I believe there is a limit for the size it should be in.

Small (48 pixels) Standard (64 pixels) Large (96 pixels). Hope This helped!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .