0

Server Dell PowerEdge R320 with two 1TB disks in RAID1 (mirror) had one of it's disks failed - the primary disk (disk0). The RAID is configured on the Smart Array. The OS running on the server is CentOS 6.6 However, after power failure, the server rebooted and the full OS was unable to load. It starts loading the OS, but it stops at "Mounting Filesystem". Stays for over an hour that way with no success or suggestion to move further.

What I did to check on things: Tried removing each disk separately - with disk1 the server does not load at all; with disk0 - loads as mentioned above. Tried booting from CentOS installation DVD and then fsck -f /dev/sda, but it returns that the disk is in use and the operation cannot be performed.

I also read for rescue mode, but I was unable to run it.

Any help/suggestions will be highly appreciated!

  • Have you tried booting from a USB stick or DVD and do the fsck from there? – Fabby Sep 16 at 20:59
  • Indeed, tried. It returns that the disk is in use and operation cannot be performed. – Anton Todorov Sep 17 at 5:49
  • On a USB stick the /dev/XdY can change. When you boot from USB, what is the output of blkid? – Fabby Sep 18 at 17:37
  • Tried booting from USB with few different OS-es (Ubuntu and CentOS), made by few softwares -total of 5-6 attempts; however, it never wanted to boot from USB. Checked the slots with other peripheral devices (mouse and keyboard - working perfectly). – Anton Todorov Sep 18 at 17:45
  • Then boot from DVD then and provide the output of blkid – Fabby Sep 18 at 17:54
0

So my new HDD just arrived today. I installed a fresh OS on it, accessed my data, and then I copied it to the new HDD. Further I removed the old/bad HDD off the RAID, formatted the old/bad HDD, then I re-configured the RAID. The data is now synchronizing between both disks.

Side effects - I had to play a bit with my data's file permissions.

Anyhow, the issue is now solved, even tho it is not the best fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.