0

The current taskbar layer is stuck on "onTop" and I would like to change it to "Normal" so it will be hidden when not focused.

A similar issue to mine can be found here but I'm unfamiliar with Linux and have no direct access to the configuration files, therefore I'm trying to solve it through the terminal.

2 Answers 2

0

To set an Icewm property of a window, you need its class and/or instance, which you can find with Icesh:

icesh list

Then click the desired window. For an Xterm, you will find xterm.XTerm as the class.instance value* in the next-to-last field.

Then one would use that value in ~/.icewm/winoptions to set a property; say, to display no title bar for Xterms:

xterm.XTerm.dTitleBar: 0

and restart Icewm.


Now, the task bar is a special window for which Icewm does not seem to honor a winoptions setting anymore (although older versions did, see the revision history). Still, there are several options for it in the preferences file, for example to set its layer to Below. If you absolutely want it to set it to Normal,

icesh setLayer Normal

or if you don't want to point-and-click,

icesh -w "$(xdotool search --class '^icewm$' search --name '^TaskBar$')" setLayer Normal

*xprop | grep CLASS can also be used to retrieve that information.

0

In preferences set:

TaskBarKeepBelow=1

or use:

icesh -T setLayer Normal

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .