0

For a while now, I get unusual activity, which comes in bursts of about 1.5 seconds. I can see the activity on XFCE's CPU graph. The intervals are not constant. Sometimes the peak is just milliseconds, sometimes it's occupying nearly the entire (1.5s) interval.

Things I tried:

  • First suspicion was was logically Firefox (my apoligies). For a couple of days, this seems actually quite sure (according to 'top', Firefox was occupying 50% on 4 CPUs, and that activity was very correlated with the peaks. Until it wasn't... I'd stopped firefox (checked absence of any process related, like firefox-bin, Web Content, Webextensions). But suddenly the peaks re-appeared.

  • Most activity was now by Window manager tasks like orage (which I also disabled - no luck).

  • Checked if somehow memory swapping was enabled. Top did not indicate any change of Swap use.

  • GIMP is a fairly reliable trigger for the CPU activity, but load continues much after closing GIMP. Strange: After load stops, closing GIMP also retriggers load.

  • Suspecting I/O activity could be involved I downloaded iotop but couldn't find any real relationship between loads and I/O activity.

  • Task manager shows more or less the same tasks as top but each with less CPU occupation.

Though this has been going on for a while, CPU activity is now frequently interfering with typing.

Questions: Is there any way to get more fine-grained load info for each task? Or any suggestion for other experiments?

The machine is an AMD A10-7860K Radeon R7, 8GB RAM Linux 4.19.25.

Load peaks: 4 CPUs near maximum (from XFCE CPU graph) Load graph from Task Manager

  • @jsotola Thanks for the reply, but been there, done that. This problem has been bugging me some time now, and I've done loads of other obvious tests, like changing the power supply. My score of 363 doesn't reflect 40+ years of microcomputer building ;) I'm quite sure this is a software issue. – jcoppens Sep 14 at 21:31
1

Solved! It's a bit of a story...

The other day I needed a ray tracing program (POVray) to create some images for my classes, and found that POVray didn't work correctly. I got several suggestions on another list, indicating POVray uses the SDL libraries. After finding, compiling and testing a couple of basic SDL programs, which showed the same issues as the POVray program.

This indicated that POVray's problems might be near the video driver (kernel modules). With some luck and reasoning, I found that the radeon driver had been blacklisted and as such didn't load. So, I re-enabled the kernel module and presto, POVray and SDL was Ok.

Inexplicably, this also solved the issue with my CPU problems! I can't explain how everything else had been working before - textmode, video, graphics programs had been fine until I hit the POVray issue. Maybe this helps someone else and saves him/her some time.

0

You may have a malware infection. Malicious software finds ways to hide so you can't always trust the reporting tools.

I would try these diagnostic techniques:

  • Disconnect your network rather then relying on iotop.
  • Boot & login directly into a shell so that your graphical environment never runs.
  • Boot into single user mode, recovery mode, or whatever special reduced-capability states your particular set-up allows.
  • This possibility has been nagging me for a while. I've mostly ignored the nagging, because a) on inactivity from me, it seems to subside and b) it doesn't appear if not triggered by a heavy load to begin with. I'll have a few incursions in that direction. Thanks for the suggestion! – jcoppens Sep 15 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.