9

I currently have a 4TB RAID 1 setup on a small, personal Linux server, which is formatted as XFS in LVM. I am interested in enabling the reflink feature of XFS, but I did not do so when I first created the filesystem (I used the defaults).

Is there a way that I can toggle the reflink feature on, without having to backup and re-create the filesystem? And if not, can I expect that feature to be implemented in the future?

1
  • By the way, the crc feature is enabled, which according to the documentation is necessary to enable reflink
    – TheSola10
    Jan 2, 2020 at 13:26

1 Answer 1

0

After reading through documentation, I've found my answer:

By default, mkfs.xfs will create reference count btrees and therefore will enable the reflink feature. This feature is only available for filesystems created with the (default) -m crc=1 option set. When the option -m crc=0 is used, the reference count btree feature is not supported and reflink is disabled. -- mkfs.xfs(8) from Debian man pages

The way I understand it, reference count btrees are a feature enabled on filesystem creation (the b-tree is generated differently), which requires CRC. CRC alone being enabled does not imply reference count b-trees being enabled.
There is most likely no way to get around this requirement currently.

3
  • By the way, if you're wondering about my personal server, I just dumped+converted everything to btrfs. idk what I expected when you can't even shrink an XFS partition without redumping
    – TheSola10
    Aug 28, 2020 at 13:59
  • What is the fud about here? xfs will enable reflinking by default. use xfs_bmap to examine the blocks used by a file. Jul 27, 2022 at 14:59
  • 1
    @user3504575 It will enable reflinking when creating a filesystem. This question is about enabling reflinking on an existing filesystem. Back when I created that filesystem, reflinking was not enabled by default.
    – TheSola10
    Jul 28, 2022 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .