1

This is the first time I've tried to install a dual boot Linux partition on a UEFI enabled machine, but I'm not even sure this is a UEFI problem.

The machine is an HP Z Book G5.

I created a Into 18.04.3LTS 64bit install USB stick with UUI and booted into Live Ubuntu no problem from it just to make sure Ubuntu ran OK.

I then choose the 'Install' option within the live running Ubuntu for no other reason than it saved a reboot.

I went through the initial choices including setting up the partitions as I wanted and choosing where to install grub and all looked ok.

I was also given the option of installing 3rd party drivers and had to select a secure boot (?) password to be able to install these.

Everything looked good and so I clicked to start the installation.

After literally a few seconds of the install running I got a message to say that the install had failed because it couldn't copy files off the disc. This was before any reboot or anything.

I rebooted and the USB install stick want recognised as bootable.

I recreated the install USB with UUI but it still wouldn't boot. Oddly at this point that stick wouldn't boot in another, much older (is non UEFI) machine either.

I created a new install USB on a new stick with UUI and the Z book wouldn't boot from that either.

I tried creating the boot stock with Rufus and eventually got a stick that would not ok on the other machine, but on the Z book it tries to bit of the stock but I get a message from the Linux boot loader that 'a serious problem occurred'.

Any ideas?

the error on booting from the install stick now

2
  • 2
    it almost sounds like you tried to install Ubuntu onto the USB install stick – jsotola Sep 11 '19 at 7:39
  • But I've recreated the install stick from the original ISO and also created a new install stick on another different usb stick. – Fat Monk Sep 11 '19 at 8:57
1

This question has already been answered a few time over on AskUbuntu - it seems it's an issue with Ubuntu installs and UEFI.

This solution worked a charm for me, but note that you do have to complete the MOX bit on reboot if you choose to install third party drivers even after the installation completes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.