0

Problem is too complex to fit in Subject line.

First, my keyboard had some dead keys, so I replaced it with a new keyboard . The replacement keyboard started to make Enter keystrokes randomly by itself. I restarted the Lenovo Ideapad, and now the internal keyboard doesn't work. Also, Kubuntu doesn't recognize the internal touchpad. I must use an external USB keyboard and mouse.

Note: After the Power On Self Test, an error code, white on black, flashes onto the screen for only one second so I can't save it.

I think the replacement keyboard is not faulty, since all buttons work, but the random keystrokes problem occurs in Windows 10. Those random keystrokes keep me from selecting anything but Windows.

ahmet@ahmet:~$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Wireless Mouse          id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Video Bus                                 id=9    [slave  keyboard (3)]
    ↳ LITE-ON Technology USB NetVista Full Width Keyboard.      id=10   [slave  keyboard (3)]
    ↳ Lenovo EasyCamera: Lenovo EasyC           id=12   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
ahmet@ahmet:~$ 

FOLLOW THROUGH POST:

the error starts with: system bootorxer not found initial

Suddenly the internal keyboard behaved, no random Enter keystrokes; then it returned, and the touchpad doesn't work, so it's back to the external USB keyboard and mouse.

  • 2
    the enter key presses automatically in linux and in windows? ... if that is true, then you have a hardware problem .... why are you posting here? – jsotola Sep 10 '19 at 23:37
  • 1
    Yes, you have a hardware problem. You can disable events from the internal keyboard and/or touchpad, so the "automatic enter" doesn't get in the way. There was at least one question for that either here or on superuser. – dirkt Sep 11 '19 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.