1

I'm working with a beaglebone black with an image based off the base debian image for these boards.

When I plug this into a monitor via the onboard HDMI and boot it, I get the linux penguine (Tux) in the top left corner and not much else until it gets to a command prompt.

I've checked the kernel parameters and quiet is not set. Does anyone with experience of this particular build know what they have done to hide all of the debug text (kernel startup, output from initramfs, output from systemd).

  • quick search reveals this directive for hiding boot messages ... perhaps you have something like that ... console=tty12 – jsotola Sep 10 '19 at 19:35
  • That's not in the params. But thinking about it, there's a lot of instructions on the internet for attaching a serial console. I wonder if I need a parameter like this to tell it to use the screen instead of serial. – Philip Couling Sep 10 '19 at 21:20
  • try adding console=tty1 (i think that is the name of the first console) ... also, try pressing ctrl-alt-F1 during boot ............. there could also be a verbosity setting somewhere – jsotola Sep 10 '19 at 22:24
  • also found a loglevel directive .... loglevel=4 – jsotola Sep 10 '19 at 23:03
  • Interestingly seeting the console=tty1 has persuaded the kernel to write to the console. But everything else (initramfs, systemd) is still hidden. – Philip Couling Sep 11 '19 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.