0

i recently installed Debian 10 Buster with KDE Plasma Desktop to my laptop. When i logon, system starts up the apps while they were open before shutdown.

I edited the file /etc/initramfs-tools/conf.d/resume as RESUME=none and ran sudo update-initramfs, but Debian still resuming from disk when i restarted my computer.

Also i have no kernel parameter like resume=UUIDblabla in /etc/default/grub file.

1

It seems like this is a feature of KDE. It'll restart applications that were previously open in the last session.

Go to:
System Settings > Startup and Shutdown > Session Management
and select something other than "Restore previous session".

You'll probably want to re-enable hibernation.

  • Thanks! When i reboot i see only KDE apps keep resume. I thought it maybe a KDE feature after i asked the question :) – frogwine Sep 9 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.