0

I'm unable to "yum install wireshark-gnome" or wireshark on a Centos 7 box. running from the SU prompt, I get this error at the end:

--> Running transaction check
---> Package wireshark.x86_64 0:1.10.14-16.el7 will be installed
--> Processing Dependency: libsmi.so.2()(64bit) for package: wireshark-1.10.14-16.el7.x86_64
--> Finished Dependency Resolution
Error: Package: wireshark-1.10.14-16.el7.x86_64 (base)
           Requires: libsmi.so.2()(64bit)
           Available: libsmi-0.4.8-13.el7.x86_64 (base)
               libsmi.so.2()(64bit)
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
libsmi-0.4.8-13.el7.x86_64 has missing requires of libsmi.so.2()(64bit)

But, trying to find that missing library I get:

[root@localhost frank]# yum provides libsmi.so.2
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.hostduplex.com
 * epel: mirrors.sonic.net
 * extras: mirror.keystealth.org
 * updates: mirror.hostduplex.com
libsmi-0.4.8-13.el7.i686 : A library to access SMI MIB information
Repo        : base
Matched from:
Provides    : libsmi.so.2




libsmi-0.4.8-13.el7.i686 : A library to access SMI MIB information
Repo        : @base
Matched from:
Provides    : libsmi.so.2

If i try to install the providing package:

[root@localhost frank]# yum install libsmi-0.4.8-13.el7.i686
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.hostduplex.com
 * epel: mirrors.sonic.net
 * extras: mirror.keystealth.org
 * updates: mirror.hostduplex.com
Package libsmi-0.4.8-13.el7.i686 already installed and latest version
Nothing to do

I also tried installing the 64-bit package:

[frank@localhost ~]$ sudo yum install libsmi-0.4.8-13.el7.x86_64
[sudo] password for frank:  Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile  * base:
mirror.hostduplex.com  * epel: mirrors.sonic.net  * extras:
mirror.keystealth.org  * updates: mirror.hostduplex.com Package
libsmi-0.4.8-13.el7.x86_64 already installed and latest version
Nothing to do

Though I'm not very experienced, it looks to me like I have the package that contains libsmi.so.2(), so what is the problem that I'm having. I updated my repos and completed yum transactions, but nothing seems to help.
Also I'd like to understand what's going on. Referring to libsmi.so.2() , what does the empty parentheses, ** "()" ** mean in the .so name. I've read about major, minor, version numbering, but I'm not sure how that fits in.

1

you need to install 64bit architeture of libsmi.so.2 what you have installed (libsmi-0.4.8-13.el7.i686) looks like libsmi for a 32 bit architecture.

For CentOS7, https://centos.pkgs.org/7/centos-x86_64/libsmi-0.4.8-13.el7.x86_64.rpm.html

try

yum install libsmi-0.4.8-13.el7.x86_64
| improve this answer | |
  • Thanks. I tried that. but its already installed. I edited my OP to reflect that. – Frank Sep 8 '19 at 23:41
  • 1
    Actually I already had libsmi-0.4.8-13.el7.x86_64 installed, as you can see in my edited question. But it must have been missing the correct file, so I " yum removed" it and the "yum installed" wireshark-gnome and let it install the dependancy. Solved my problem. Thanks. – Frank Sep 9 '19 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.