0

Looking to upgrade from a working Linksys router running OpenWRT Kamikaze, I selected the TP-Link Archer C7 based on happy Reddit reviews of OpenWRT running smoothly on it. It seemed lucky to get the v4 from ebay since that one has the fastest CPU of all the versions. After installing OpenWRT 18.06.4 and configuring, everything seemed to work except that the WAN port connected to my Netopia DSL model would not acknowledge its physical connection. The ethernet light on the modem, likewise, did not come on.

Interfaces section showing WAN not connected

Switch showing no link for WAN port

Nothing I connected the WAN port to would cause its indicator to light - not the modem, another router, or even one of its own LAN ports. Several different ethernet cables, all working on other ports, were tried. Switching the protocol from static IP to DHCP made no difference. Setting the MAC address of the WAN port to that of the old router had no effect. Resetting the configuration back to defaults did not help.

I did not test the router before flashing it, so maybe the WAN port was physically defective. But others have reported issues with the WAN port for the TP-Link Archer C7 upon switching to OpenWRT - though none with a solution to my problem. But in following one of these leads, I attempted leaving the router and modem off for several minutes before booting them, and found that the WAN worked. My whole network was perfect then and I thought it would stay that way, but after a week the WAN link went back down and I haven't been able to restore it since. One thread I found suggested that the issue might have to do with LAN devices switching between gigabit and 100 mbs speed, triggering a bug, and that connecting the LAN through a separate switch would prevent the bug from being triggered. I haven't been able to test that.

  • If openwrt does not cut it, it is possible to revert back to the stock firmware. I would use their forums. – Rui F Ribeiro Sep 8 at 16:33
  • 1
    Meanwhile, without an external switch, you can see if limiting the device to 100mb/s "fixes" the problem. If the driver supports ethtool, something like ethtool -s eth0 advertise 0x8. – A.B Sep 8 at 18:09
  • @A.B I like that suggestion, and apparently ethtool can be installed in openwrt. I will need to install the package without the external network being available though. I'll work on that. – Chris Jenks Sep 8 at 22:02
  • I tried to install ethtool to see if setting the WAN port to 100mb/s would render it available, an improvement over my solution below, but the package is unavailable in OpenWRT. – Chris Jenks Sep 12 at 18:32
0

The acceptable solution I've found is to reprogram one of the LAN ports to operate as the WAN port. My fear that this would limit my router to being only a switch was unfounded. All I had to do was plug the DSL modem into LAN port #1 and reconfigure the interfaces as shown.

reprogrammed interfaces

The router is routing between the external network and my web server. I only has to sacrifice one LAN port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.