-2

I am trying to install https://kali.sh/xfce4.sh in my kali linux to use GUI. However, if i type "sudo wget https://kali.sh/xfce4.sh", it says this:

--2019-09-08 16:43:20--  https://kali.sh/xfce4.sh
Resolving kali.sh (kali.sh)... 45.79.158.143
Connecting to kali.sh (kali.sh)|45.79.158.143|:443... 
failed: Resource temporarily unavailable.
Retrying
  • 3
    What debugging have you tried? At least at the moment, kali.sh is down. – Philip Kendall Sep 8 '19 at 7:57
  • 3
    There is nothing you can do on your side to make a remote website work, short of contacting the admins of that website. – Kusalananda Sep 8 '19 at 7:59
  • ok ill try again – 00 0 Sep 8 '19 at 23:54
  • still doesn't work – 00 0 Sep 9 '19 at 3:46
0

It appears that the connection is timing out, probably because of a too big of a load on the servers. Please try again later.

|improve this answer|||||
  • I don't think so... it just doesn't work TT – 00 0 Sep 8 '19 at 11:16
  • Maybe the server is misconfigured.. You should contact the responsible webmaster in order to solve this problem. – Sir Muffington Sep 9 '19 at 12:05
0

If you can't download it, Here's what's inside it :-

#!/bin/bash

# A quick BASH script that installs noVNC and sets up an Xfce4 session,
# accessible through a browser on port 5901 TCP. Tested against Kali Linux Xfce4 "full" installations.
# If running this on Azure or other virtual hosting, don't foret to allow ingress TCP 5901 .


# Configure the following parameters if needed:
###############################################
resolution="1280x720x16"
display_number=1
web_vnc_port=5901
###############################################

clear
echo -e "\n[*] Setting up \e[31mKali in a Browser\e[0m, generating ~/start.sh\n"
sleep 2
cat << EOF > ~/start.sh
#!/bin/bash
clear
echo -e "\e[31m\n[*] Starting up noVNC.\e[0m"
export DISPLAY=:$display_number
Xvfb :$display_number -screen 0 $resolution &
sleep 5
# Start up Xfce is available, otherwise assume Gnome
if [ -f /etc/xdg/xfce4/xinitrc ]; then
    startxfce4 2>/dev/null &
fi
x11vnc -display :$display_number -shared -nopw -listen localhost -xkb -bg -ncache_cr -forever
websockify --web /usr/share/novnc $web_vnc_port 127.0.0.1:5900 --cert=self.pem -D
ip="\$(host -t a myip.opendns.com resolver1.opendns.com|tail -1 |cut -d" " -f4)"
echo -e "\e[31m\n[*] Kali in a Browser is set up, you can access https://\$ip:$web_vnc_port\e[0m"
echo -e "[*] Don't forget to open up incoming port TCP $web_vnc_port if you have a firewalled host.".
EOF


chmod 755 ~/start.sh
clear
echo -e "\n[+] Installing pre-requisites, enter sudo password if asked.\n"
sleep 2
sudo apt-get update
sudo apt-get -y dist-upgrade
sudo apt-get -y install novnc websockify x11vnc xvfb
sudo apt-get clean
sudo ln -s /usr/share/novnc/vnc.html /usr/share/novnc/index.html
clear

echo -e "\n[+] Generating SSL cert. Please fill in details, then run \e[31m./start.sh\e[0m\n"
sleep 2
openssl req -new -x509 -days 365 -nodes -out self.pem -keyout self.pem
|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.