2

I have a Linux console running in a virtual machine (QEMU/KVM). Inside the VM I use GPM in order to select and paste text with the mouse. However, when I enter the VM's spice virt-viewer window in my graphical desktop the graphical mouse cursor of the desktop is completely at a different position than the GPM mouse cursor. That is annoying and it means that some areas of the VM's text window cannot be reached without entering and exiting the spice window several times.

How do I align/synchronise the mouse cursors of spice/desktop and GPM?

I cannot install an additional program in the VM because it is a server. It must work with GPM alone. Perhaps QEMU needs some config options?

1 Answer 1

1

I found this in the ArchLinux wiki page (Last edited on 27 April 2020)

QEMU or VirtualBox

The default mouse emulated by QEMU and VirtualBox has severe problems in both gpm and x with positioning and clicking. The position becomes unsynchronized with the host, so there are areas that can't be hovered over without repeatedly exiting and re-entering the window. Clicks register in a different location than the cursor was showing at.

Both QEMU and VirtualBox solve this problem by providing emulation for a USB tablet, which gives absolute positioning. (libvirt uses this automatically.) However, the gpm only knows how to use the emulated mouse in relative positioning mode, so these problems remain.

The article goes on to suggest some solutions. It can be found here.

1
  • Thanks, I will check that next time I open that VM!
    – Ned64
    Commented Nov 22, 2020 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .