0

I have Ubuntu 19.04 OS installed on my Dell laptop. When I close the laptop lid and open it up to resume my work I end up seeing TOTAL WHITE SCREEN. I will have to power down and restart my laptop again after a few minutes for the luck to come by my side.

I get the below output when I run inxi -G in my command line:

Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: radeon resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 19.0.8 

When I run cat /proc/cmdline on terminal, I get:

BOOT_IMAGE=/boot/vmlinuz-5.0.0-27-generic root=UUID=c6435873-c6f7-440e-b4eb-f390052fa747 ro quiet splash vt.handoff=1

When I run sudo lshw -c video, I get:

  *-display                 
       description: VGA compatible controller
       product: Skylake GT2 [HD Graphics 520]
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:125 memory:de000000-deffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff
  *-display
       description: Display controller
       product: Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 81
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:126 memory:c0000000-cfffffff memory:df200000-df23ffff ioport:e000(size=256) memory:df240000-df25ffff

When I run sudo lshw | grep -A5 "Moth" && lshw | grep product | head -n1 as superuser, I get the output below:

       description: Motherboard
       product: 052K07
       vendor: Dell Inc.
       physical id: 0
       version: A00
       serial: /G061762/CN129635BM0001/
    product: Inspiron 5559 (06B2)

When I run cat /etc/systemd/logind.conf | grep -i LidSwitch, I get:

HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
#LidSwitchIgnoreInhibited=yes

My current display resolution: 1920 x 1080 with 60.00Hz refresh rate and 100% scale.

I would appreciate your help in resolving this issue.

  • 1
    1) Please advise what your laptop is set to do when you close the lid: A] Sleep B] Hibernate C] Shut Down D] Nothing. 2) Please also advise what you get when you run sudo lshw | grep -A5 "Moth" && lshw | grep product | head -n1 Advise by clicking edit and adding that useful information to the question. Please do not click Add Comment, please use edit instead. Editing tips are at unix.stackexchange.com/editing-help#code . – K7AAY Sep 5 '19 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.