1

I have been following the instructions on Get Docker Engine - Community for Debian in attempts to add the Docker repo. I have tried a number of combination, but always get the " does not have a Release file" message for whatever release I put in /etc/apt/sources.list.d/docker.list

I have viewed the related SO question for Ubuntu Docker Repository Does Not Have a Release File on Running apt-get update on Ubuntu

I ran the two following commands to add the key, which I think is correct

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -C
sudo apt-key fingerprint 0EBFCD88

I have tried using Continuum, trusty, xenial, bionic, etc. Yeah, I believe most of those names are for Ubuntu so they aren't going to work. Continuum was found by executing lsb_release -cs. Does anyone have any idea what I should use so I can use apt to install Docker on MX Linux 18.3? Thanks!

Specific error message is

Err:12 https://download.docker.com/linux/debian Continuum Release
  404  Not Found
Reading package lists... Done
E: The repository 'https://download.docker.com/linux/debian Continuum Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.