1

So i have recently started using i3 on my arch install. slowly i setup my config files with keybinds and all. About 2 days ago i install light ( to control screen brightness ) and it was working fine. but now suddenly i noticed that pressing the brightness keys did nothing. after trying the command light -S 100 in the terminal nothing happend. then i ran it as sudo and it worked. because the command suddenly needs to be run as sudo my keybind wont work. my keybinds for brightness control in my i3 config files are:

bindsym XF86MonBrightnessDown exec sudo light -U 10
bindsym XF86MonBrightnessUp exec sudo light -A 10

is there anyway i can make light work without sudo? or im i stuck with using light as sudo in the terminal to control my screen brightness?

1

2 Answers 2

1

You could use the desrcibed way of adding yourself to the video group as explained here .

Or you can set the SUID bit by doing sudo chmod +s /usr/bin/light which wont require you to type sudo password everytime. Also you could set a keyboard binding to go with this.

Hope this helps.

0

Add yourself to the video group.

sudo usermod -a -G video username

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.