0

I changed window managers and now need to be able to change /sys/class/backlight/intel_backlight/brightness (because the new wm cannot change screen brightness natively).

I created a user group called brightness, added myself to the group, and ran sudo chown root:brightness /sys/class/backlight/intel_backlight/brightness.

Now, every time I restart my computer the group ownership of the file changes to video instead of brightness. Previously, this file was owned by root:root and remained that way.

$ ls -l /sys/class/backlight/intel_backlight/brightness 
-rw-rw-r-- 1 root video 4096 Sep  4 11:10 /sys/class/backlight/intel_backlight/brightness
$ sudo chown root:brightness /sys/class/backlight/intel_backlight/brightness 
$ ls -l /sys/class/backlight/intel_backlight/brightness 
-rw-rw-r-- 1 root brightness 4096 Sep  4 11:10 /sys/class/backlight/intel_backlight/brightness

So now I have to chown that file every time I restart my computer. What is happening?

(I am running Ubuntu 19.04)

5
  • Have you tried to add yourself to video instead?
    – xenoid
    Sep 4, 2019 at 16:22
  • @xenoid, I could do that, but I'm curious to know why the ownership is changing in the first place.
    – Umang
    Sep 4, 2019 at 16:59
  • 2
    @Umang because the /sys filesystem is ephemeral - you can try using udev instead as discussed here: udev doesn't want to run chgrp and chmod Sep 4, 2019 at 17:16
  • @steeldriver, Thank you! I read up about /sys and the link you pointed to. I got udev to change the permissions. It works perfectly. If you want to post an answer, I'll mark this as solved.
    – Umang
    Sep 4, 2019 at 18:05
  • @Umang how to do that with udev? Dec 24, 2022 at 19:34

0

You must log in to answer this question.

Browse other questions tagged .