1

I can use goobook to create a google contact with NAME and EMAIL but I need to add a PHONE.

2
  • goobook add can either read an e-mail or take 2 parameters from the command line. I guess that currently you're adding new contacts using the latter, right? Sep 8, 2019 at 19:31
  • Anyway, it wasn't very hard to modify goobok source code so that it accepts phone number parameter with add option like that: ./goobook add my-test-with-phone [email protected] 666666666 Sep 8, 2019 at 19:47

1 Answer 1

1
+100

I have patched goobook to accept a phone number when adding new contacts. Clone my forked repository:

git clone https://gitlab.com/ardrabczyk/goobook && cd goobook

Now you can follow the instructions in README.rst. In this case, as you're now installing goobook from source just do this:

sudo python3 ./setup.py install

Personally, I don't like installing packages globally and using sudo if there's no such need so consider doing this instead:

python3 setup.py install --user

You won't need to enter root's password and goobook will be installed to ~/.local/bin. Check the new help for add command:

$ ~/.local/bin/goobook  add -h
usage: goobook add [-h] [NAME] [EMAIL] [PHONE]

Create new contact, if name and email is not given the sender of a mail read
from stdin will be used.

positional arguments:
  NAME        Name to use.
  EMAIL       E-mail to use.
  PHONE       Phone number to use.

optional arguments:
  -h, --help  show this help message and exit

Add a new test entry with a phone number:

~/.local/bin/goobook  add fork-goobook [email protected] 789456123

Make sure it was created correctly:

$ ~/.local/bin/goobook  query 789456123

[email protected]   [email protected]

Keep in mind that the change I've introduced has not been formally accepted by goobook developers and that you're now using a fork.

5
  • Notice this bug: gitlab.com/goobook/goobook/issues/82. It's also present in my fork as it has not yet been solved by upstream developers. Sep 9, 2019 at 1:11
  • Thank you so much @Arkadiusz ! I really appreciate your work. I hope the bug can be solved soon, then this app will be perfect for use.
    – desgua
    Sep 9, 2019 at 12:20
  • goobook version 1.9 does NOT have that bug. Would I be asking too much for you to fork that version? Again thank you so much for looking at this!
    – desgua
    Sep 9, 2019 at 13:34
  • 1
    I think it would be much better to fix this bug against the current version. It now works for me, I think so at least. Do git fetch and switch to issue-82 branch Sep 9, 2019 at 14:51
  • I feel I can't thank you enough! I'm very grateful. Thank you!
    – desgua
    Sep 9, 2019 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .