0

Italy

I have some legacy software capable of running on Solaris. It booted in a PC from SCSI disks (BIOS MBR+Legacy GRUB). The operating system is in a partition of type BF00 (Solaris root). Time ago, I managed to "virtualize" this system in a VirtualBox VM. This solution works but now for certain reasons I need to port everything on a Windows 2019 failsafe Cluster with Hyper-V.

If I create a type-1 Hyper-V VM, the system boots from IDE but does not work because the legacy software requires to run on SCSI. Unfortunately Hyper-V type 1 does not support booting from virtual SCSI.

It is possible to create a Type 2 Hyper-V VM and boot UEFI SCSI disks at boot time, I therefore imagined to create a boot disk with GRUB2 (Ubuntu) and chainload the MBR Solaris system on SCSI. Unfortunately in this case I could not find a way to see the BF00-type partition, no matter what insmod (I found it should be ufs1/2 or zfs or part_sunpc, tried all). At grub2 command level I see the SCSI disks (with ls) but the BF00 (Solaris root) partition cannot be read (unknown filesystem), I can't load any kernel nor chainload+. If I start the VM with UBUNTU, the Solaris SCSI disks are readable and mountable, mount shows ufs file system type.

Can anyone please suggest any method? Ideas highly welcome. I also tried Super Grub2 CD without success, it boots but cannot see any file in the SCSI Solaris partition.

Thank you in advance for your help.

Rob

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.