1

I don't have a any deep knowledge regarding the server, but recently I got some issue with mail on one server.

I have tried this command

telnet 77.242.116.45 587

and it gives me

telnet: Unable to connect to remote host: Connection timed out

I am attaching the port image and I don't have any idea is which post is running and which is not.

enter image description here

can anyone please guide me on this.

After trying Stephen Kitt's solution I got this error.

Connection closed by foreign host.

enter image description here

1 Answer 1

1

The process listening on port 587 is bound to 127.0.0.1, so it will only accept connections on localhost; you should find that

telnet 127.0.0.1 587

will open a connection.

If you need to change that, you’ll have to change the configuration of whatever program is running so that it listens on the appropriate addresses.

5
  • I have updated the issue I got "Connection closed by foreign host" after running your given command. @StephenKitt Sep 2, 2019 at 9:38
  • That’s normal, you’re not sending anything on the connection so the server closes it. The fact that you get a 220 response proves that your connection attempt was successful. Sep 2, 2019 at 9:40
  • I am still not able to send mail through 587 port form this server. My server is running on IP, is that domain required to send mail? @StephenKitt Sep 2, 2019 at 9:45
  • Where are you trying to send mail from? If it’s somewhere other than the mail server, you need to change the configuration so that it will listen on the appropriate addresses. Otherwise, you need to configure your sending program to connect to 127.0.0.1. Sep 2, 2019 at 10:01
  • I am sending a mail threw "Zivver" ( my mail server), the issue is the port and now it is solved. port is closed by the server guy. Sep 28, 2019 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.