1

I have following Service configuration:

[Unit]
Description=Watch Bovon Handyhalterung
After=network-online.target
Wants=network-online.target

[Service]
ExecStart=/home/pi/Documents/bin/amazon-pricewatcher -url="https://www.amazon.de/Bovon-Handyhalterung-Verstellbarer-Handyhalter-360%C2%B0Rotation-Schwarz/dp/B077GNWNL8?pf_rd_p=0f6687bc-b0cb-44d9-9696-138c1879ad4f&pd_rd_wg=e0fEm&pf_rd_r=CA5EYTP96QYVH336GFFR&ref_=pd_gw_cr_simh&pd_rd_w=xOczT&pd_rd_r=ee8c3a4d-3220-417a-bccf-435aaf791d61" -email="tobiwimma04@gmail.com"

[Install]
WantedBy=multi-user.target

It says it failed due to bad setting.
If I use a shorter url flag, it works, so I assumed that the url flag is too long (maybe this makes the command too long)

Thanks for your help!

  • Does the shortened URL also contain % sequences (like the %C appearing in your example)? I wonder if it's the presence of those (rather than the length) that's the problem – steeldriver Sep 1 '19 at 17:04
  • No it didn't. It might really be the problem. But how can I fix this? – Tobi696 Sep 1 '19 at 17:51
  • 1
    You could try replacing % in the URI by %% as described in the Specifiers section of the systemd.unit manpage – steeldriver Sep 1 '19 at 18:13
  • Or try using single quotes around the URL instead of double quotes. – Edward Sep 1 '19 at 18:23
  • Now it works, thank you! – Tobi696 Sep 1 '19 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.