11

When I had to login in a site, Chrome used to offer me a number of possible user names and later the password associated with the user I choose (provided that I saved the user-password association previously).

Now Chrome still offers the correct possible users but then offers no password, I have to enter the password (if I remember it, that is, otherwise it's password resetting) and, after a successful login, Chrome ask for permission to save the password. I give permission, of course, but next time I login it's again no password remembered.

If I open the Settings->Passwords screen I see (the equivalent of)

Offer to save passwords [YES]
Auto Sign-in            [YES]

and below

Saved Passwords
    Saved passwords will appear here

that is, no password is really saved.

Final consideration, the same page permits to View and manage saved passwords in your Google Account and if I go there I can see all my sites, my users and my passwords except, important exception! that some of these passwords are stale.

I'm on Debian Sid, Chrome is Version 76.0.3809.132 (Official Build) (64-bit) from Google's official .deb

What can I do to fix this annoying problem?

UPDATE

This is what I get when I launch Chrome from the shell

$ google-chrome
[18891:18891:0906/221132.855189:ERROR:sandbox_linux.cc(369)] InitializeSandbox() called with multiple threads in process gpu-process.
[18856:18990:0906/221136.514201:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
[18891:18891:0906/221143.906640:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
[18856:18996:0906/221151.512723:ERROR:password_syncable_service.cc(191)] Passwords datatype error was encountered: Failed to get passwords from store.

In particular, Passwords datatype error was encountered: Failed to get passwords from store. seems relevant wrt my issues.

5
  • maybe ur chrome cache is full. try to clear/increase it...
    – Siva
    Sep 3, 2019 at 13:37
  • 2
  • @JL2210 The related questions: askubuntu one, I don't use a keyring, everything worked nicely until some time ago; superuser one, the accepted answer can be superposed with what I have described in my question. I'll see later all the remaining answers. Thank you for the suggestions.
    – gboffi
    Sep 4, 2019 at 12:53
  • make sure that you're syncing the data to/from the google account within your chrome browser. It might be worth checking that and also including pastbin link to more logs.
    – ILMostro_7
    Sep 6, 2019 at 20:29
  • I guess that is not what you want to hear and not the solution to your question, but it is recommended in general to use a separate password store: maketecheasier.com/are-browser-password-manager-good-enough
    – Martin
    Sep 10, 2019 at 7:18

3 Answers 3

23

Sometimes a couple of login files get corrupt, and stop google-chrome from saving the passwords.

To fix it, close google-chrome. Terminal to the following directory and remove the two files, Login Data and Login Data-journal.

cd ~/.config/google-chrome/Default
rm 'Login Data'
rm 'Login Data-journal'

Now open Chrome and URL to 'Chrome://settings/passwords' and see if the passwords have returned under 'Saved Passwords...'. Try saving a password and check the above password URL to see if it is now being saved.

2
  • If you have installed Chromium via Snap, the solution is the same except that you need to substitute the directory ~/snap/chromium/common/chromium/Default for the directory in the first line. Sep 1, 2020 at 10:39
  • Wow, that worked. Thanks! A note that that only fixes the default profile. You need to do the same in the Profile 1, Profile 2, etc folders next to the Default folder. Also I noticed that some of those folders also had a Login Data 2-journal folder. Not sure if those needed to be deleted too, but I deleted them too. Now all my profiles offer my saved passwords! May 4, 2021 at 8:56
0

I had similar issue "Saved Passwords" "Saved passwords will appear here" was empty while my usernames and passwords were saved properly and worked. I was playing a bit with great Python script https://rtfm.co.ua/en/chromium-linux-keyrings-secret-service-passwords-encryption-and-store/ and found that by removing password (database rows) that can't be decoded by my master password I got the "Saved Passwords" list back.

To be more technical. I created backup of may "~/.config/google-chrome/Default/Login Data" (Fedora 33) Chrome config (sqlite3 database). Exported my original "logins" table (e.g. by "sqlitebrowser" tool), used editor to remove rows/passwords that can't be properly decoded (all from IDs 1 to 57) and used ~/.config/google-chrome/Default $ sqlite3 Login\ Data 'delete from logins' && sqlite3 Login\ Data ".read /home/mj//logins-ok.sql" && google-chrome to check that it works.

That took me a few hours of debugging a few hundreds of my logins/passwords are back. I tried to report it as new Chrome bug. IMO it is caused by some decode crash, or not valid utf8 results of the decode going to the search/sorting operation.

0

I had the same problem in Ubuntu 20.04. I fixed the issue by renaming the existing google chrome profile. Below are the steps of it.

  1. Login into your account through ssh.
  2. cd ~/.config
  3. Rename the existing google chrome profile.
    mv google-chrome google-chrome-old
    
  4. Start google chrome browser.
  5. Sign in with your account again and sync it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.