0

I want to install Qogir theme on Xfce (I'm using Debian).

I've downloaded and extracted the files in the ~/.local/themes directory, then went to Appearance and selected Qogir in the list of "styles" (sorry if the words doesn't match precisely since my interface is in french). I've also chosen Qogir for the window theme (the "decorations"). This works, as well as the icons I've downloaded. However the content of the windows doesn't change, and instead of looking very Qogir flat design, it's looking like really old design. I've read that Xfce is using GTK2 for the rendering of some applications, and I've read in the Xfce doc that :

A GTK+ theme is the theme of the toolkit (buttons, textfields, etc). Most of the GTK+ themes need their own theme engine, make sure you have that theme engine installed with the same prefix as the GTK+ toolkit.

So I installed the engines with apt, and nothing changed but I guess that's normal since the doc says the engine should have the same prefix as the GTK+ toolkit. My questions are : what exactly is the GTK+ toolkit ? It that my Qogir theme ? How can I find those installed GTK2 engines to modify their prefix ? And... how can I modify the prefixes ?

Thanks a lot for your help!

  • The readme says you need gtk2-engines-murrine and gtk2-engines-pixbuf. And install the theme with ./install.sh [options] (don't know if it works if you extract it and no, I didn't test the install script). – Freddy Aug 31 at 14:57
  • And I had installed them. Thing is when the readme says to install the theme with ./install.sh, it is if you download the theme from the github. And I had downloaded from xfce-look... And the folder didn't have an install.sh file... So what I did after reading your comment, just to be sure, is removing what I had installed, and then download from the github, and then run ./install.sh and... it worked. So thank you! If I knew it would be that easy. Next time I'll try and download directly from the github. :) – Chloé Sep 1 at 18:53
  • Glad it worked! You can write this up as a short answer and I'll upvote it. You can accept your own answer after two days. See Can I answer my own question? – Freddy Sep 2 at 6:37
  • Thanks @Freddy, I've written the answer! – Chloé Sep 3 at 13:39
  • Thanks for the answer! – Freddy Sep 3 at 13:41
1

Found solution thanks to Freddy's comment :
I had downloaded the theme via a theme website and the .tar.xz archive didn't contain any installation file. So I've downloaded the theme from the github of the theme, which contains a install.sh file, wich I ran (as written in the README). And it worked!
To be noted: I had previously installed the necessary engines for this theme (which were also indicated on the README). I guess the installation made the connection between the engines and the theme, which I didn't manage to do on my own.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.