2

I'm giving Pop!_OS (based on Ubuntu 19.04) a try, and am experiencing a very annoying issue with the mouse wheel (a Logitech MX Anywhere 2).

First of all the scrolling speed is very slow; I read somewhere about the Solaar app for Logitech mice, that would allow me to configure some mouse settings, including scroll wheel speed. Unfortunately, I cannot see any settings in the app:

Solaar

After some more googling, I found about imwheel. I installed it, changed some values in ~/.imwheelrc, and got a mouse wheel speed closer to what I had on Windows. I can't say it's as smooth, but it's usable. However I'm not that happy with this solution, as this utility does not seem to be installed as a service, and needs to be started manually. So much for the user experience (I was expecting something in Pop!_OS settings).

Now the very annoying part: when I start spinning the mouse wheel in Firefox or Chrome, very often the first spin is just ignored, and the scrolling starts the second or third time I hit the wheel. This makes the mouse wheel pretty much unusable for me, and forces me to use the scrollbar to get a consistent scrolling.

Is there a solution to this problem?

2 Answers 2

2

Believe it or not but changing my batteries of the mouse fixed stuttering / slow mouse wheel. Although everything else worked perfect with the older batteries, the scroll wheel was not working reliable... I should have checked the batteries before changing code /settings within the os... o well, lesson learned. The solution might be less complex than expected ;-)

1
  • The fact that scrolling was perfectly fine in Windows but abysmal elsewhere else confused me. Since scrolling in Windows seemed fine I had assumed it was something else even though I knew my mouse battery was low. Nov 3, 2021 at 20:02
0

You can set imwheel to run on startup in your desktop environment settings. On GNOME you should probably make a .desktop file (follow the instructions at https://stackoverflow.com/a/8290652/5495101 and use the imwheel command in the Exec= field).

For the first scroll spin ignored, I had the same problem on Arch Linux, and fixed it by installing xf86-input-evdev (on Ubuntu based distros the package name should be xserver-xorg-input-evdev) and rebooting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .