1

Right now I have a kiosk apps set up on a mini PC with lubuntu 18.10. The apps run on Chrome. I create a command to autostart Chrome instance everytime the PC starts up.

But sometimes, Chrome doesn't start, and from logs I know the error is this:

[1680:1680:0830/083742.498300:ERROR:edid_parser.cc(313)] invalid EDID:
human unreadable char in name

[1715:1715:0830/083742.790840:ERROR:sandbox_linux.cc(368)]
InitializeSandbox() called with multiple threads in process
gpu-process. /home/soltova/Documents/chrome.sh: line 17:  1680 Killed 
/usr/bin/google-chrome --disable-web-security --test-type
--user-data-dir --kiosk --incognito http://localhost/html12/

How do I approach this issue, so that everytime the PC start up, Google Chrome shows up?

Start up script:

#!/bin/bash 

exec > /home/soltova/Documents/chrome-run.log 
exec 2> /home/soltova/Documents/chrome-run.err
#xset dpms force off 
function online {   ## Test if online - prototype code  
 wget -q -O /dev/null --timeout=5 http://www.google.com  
 return $?
}

until online do   sleep 5 done

#xset dpms force on     
/usr/bin/google-chrome --disable-web-security --test-type --user-data-dir --kiosk --incognito http://localhost/html12/
  • what does the startup script look like? can you update your question with it? – Bart Aug 30 at 6:59
  • updated my start up script – Van Dominic Aug 30 at 10:11
0

There is a common Google Chrome error when trying to run it in Linux due to Chrome’s GPU usage.

Unfortunately there isn’t a clear fix yet, this is a is an easy solution to make it possible to use Chrome browser when the following error message appears.

This error affects to all Chrome versions:

  • Google Chrome stable
  • Google Chrome beta
  • Chromium

Solution

The easiest solution is to avoid using GPU hardware acceleration with the following flags: --disable-gpu --disable-software-rasterizer

google-chrome --disable-gpu --disable-software-rasterizer

Parameter --disable-gpu definition:

Disables GPU hardware acceleration. If software renderer is not in place, then the GPU process won't launch

Parameter --disable-software-rasterizer definition:

Disables the use of a 3D software rasterizer

  • i see, but does using this flag will have issues in rendering my chrome ? because i am actually running unity on web for my app, isnt disabling gpu making it more slower? – Van Dominic Aug 30 at 10:12
  • not sure, presumably not. please also see bugs.chromium.org/p/chromium/issues/detail?id=906455#c14 – Bart Aug 30 at 11:53
  • Allright thanks for the help! – Van Dominic Sep 2 at 6:52
  • hey man, i tried this and it does significantly lower the performance to render image/videos, so it looks a bit laggy....but i do some research and found out about --no-sandbox flags, do you know something about this? – Van Dominic Sep 5 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.