1

Have a strange behavior on laptop Dell e6430, Debian Buster. After installation several days all was fine. Then I faced the situation that it cannot see my home 2.4ghz WiFi network and only 5ghz seen(it is on the same device).

The iw dev wlp2s0 scan brings me many neighbor WiFi networks, but not mine. In same time windows pc can see all networks.

I put ON the WiFi routing option on mine android phone - other windows PC see and my router and phone WiFi point and neighbors. But Debian laptop still see only neightbors and 5ghz WiFi on mine main router.

Then I switch channel option at 2.4ghz config on my router from Auto to 7. Restarted. And magically my laptop started to see and my router and my phone. Switching channel back to AUTO, brings me back to the problem.

iw reg get global country GB: DFS-ETSI (2402 - 2482 @ 40), (N/A, 20), (N/A) (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS (57000 - 66000 @ 2160), (N/A, 40), (N/A)

Switching iw reg set to anything else(US, GB, RU) gives me nothing.

Controller is: 02:00.0 Network controller: Broadcom Limited BCM43228 802.11a/b/g/n Drivers refreshed. Besides yesterday all was working perfectly.

iw phy brings me Frequencies: * 2412 MHz [1] (20.0 dBm) * 2417 MHz [2] (20.0 dBm) * 2422 MHz [3] (20.0 dBm) * 2427 MHz [4] (20.0 dBm) * 2432 MHz [5] (20.0 dBm) * 2437 MHz [6] (20.0 dBm) * 2442 MHz [7] (20.0 dBm) * 2447 MHz [8] (20.0 dBm) * 2452 MHz [9] (20.0 dBm) * 2457 MHz [10] (20.0 dBm) * 2462 MHz [11] (20.0 dBm) * 2467 MHz [12] (20.0 dBm) * 2472 MHz [13] (20.0 dBm) * 2484 MHz [14] (disabled)

So only ch 14 disabled. Thus the router is on channel 12 Besides - I cannot understand why I cannot see WiFi access-point on android device till put from AUTO to Ch7 on router - they have no connections at all.

Please advice where to dig... I have no ideas for now.

Added: just found this issue. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=636119

Not working WiFi on 12, 13 and 14 channel. But it is 2011 year issue... And in mine case I see 12 and 13 in the list of available ones. But cannot see any WiFi devices that are on this channels...

Working further... apt-get purge broadcom-sta-dkms firmware-b43-installer Then reinstalled apt-get install firmware-b43-installer. Here I have output of iwlist chan from 1 to 11 channels. So there is no 12-14. On the broadcom-sta-dkms driver (wl) the 12-14 channels were shown but not worked.

Updated: full reinstall downgrading all packets to stable have no effect. Still no 12-14 ch availavle, but they are shown in freq query!

Update: It seems there is something with regulatory domain. I don't remember what I did exactly. But for now crda is not working. Here what I have:

iw list
* 2467 MHz [12] (20.0 dBm) (no IR)
* 2472 MHz [13] (20.0 dBm) (no IR)
* 2484 MHz [14] (20.0 dBm) (no IR)

And here:

/var/log# crda
COUNTRY environment variable not set.

And here:

Sep  3 20:53:21 wrk wpa_supplicant[491]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Sep  3 20:53:21 wrk systemd-udevd[6208]: Process '/sbin/crda' failed with exit code 255.
Sep  3 20:53:24 wrk wpa_supplicant[491]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Sep  3 20:53:24 wrk systemd-udevd[6208]: Process '/sbin/crda' failed with exit code 255.

Seems crda failed... editing config gets nothing.

0

Could you set it to manual and do a sudo iw dev <interface> scan? Search your AP in the list and lock at the "Country" line. If it set to e.g. ROW (Rest of world) or US, the android phone chooses channel 12 despite sending that it is in a region where this channel isn't allowed. This could cause the adapter to ignore this AP if it uses a channel which is forbiten in its advertised country. Then a firmware update could help.

  • iw dev wlp2s0b1 scan gives output of available connections. And there is no 2.4ghz of my WiFi router. just 5ghz and some neighbors WiFies, as it was. – Prosto Chel Aug 29 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.