I am using Linux Mint 12 and currently have the Mate desktop running. The icon in the upper right showed their were updates. Tried to do it and it said that

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f

The details are:

The following packages have unmet dependencies:

mint-artwork-gnome: Depends: gtk2-engines-clearlooks but it is a virtual package Depends: mint-backgrounds-lisa but it is not installed

sudo apt-get install -f gives this output:

Reading package lists... Done Building dependency tree
Reading state information... Done

Correcting dependencies... Done

The following extra packages will be installed:
mint-backgrounds-lisa The following NEW packages will be installed:
mint-backgrounds-lisa 0 upgraded, 1 newly installed, 0 to remove and 32 not upgraded. 4 not fully installed or removed. Need to get 0 B/3,003 kB of archives. After this operation, 3,265 kB of additional disk space will be used. Do you want to continue [Y/n]? y (Reading database ... 482703 files and directories currently installed.) Unpacking mint-backgrounds-lisa (from .../mint-backgrounds-lisa_1.1_all.deb) ... dpkg: error processing /var/cache/apt/archives/mint-backgrounds-lisa_1.1_all.deb (--unpack):
trying to overwrite '/usr/share/gnome-background-properties/linuxmint-lisa.xml', which is also in package mint-artwork-kde 2.0.1 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing:
/var/cache/apt/archives/mint-backgrounds-lisa_1.1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

If I try and install the latest version of Chromium by double-clicking the deb file is says:

gdebi-gtk Broken Dependencies

Your system has broken dependencies. This application cannot continue until this is fixed. To fix it run 'gksudo synaptic' or 'sudo apt-get install -f' in a terminal window.

If I run 'gksudo synaptic' Synaptic comes up and says:

(as superuser) You have 1 broken package on your system!

Use the "Broken" filter to locate it.

The Broken filter shows:

Synaptic Broken Installed Version Latest Version Description
mint-artwork-gnome 2.6.20 2.6.20 Default Artwork for Linux Mint

Trying to reinstall the above package gives:

An error occurred The following details are provided:

E: /var/cache/apt/archives/mint-backgrounds-lisa_1.1_all.deb: trying to overwrite '/usr/share/gnome-background-properties/linuxmint-lisa.xml', which is also in package mint-artwork-kde 2.0.1

One easy solution is probably to not run Mate with Linux Mint (this is my first try), but just wondering if this is fixable.

4 Answers 4


An alternative to manually hacking dpkg data files is to use the --force-overwrite option to dpkg, e.g.,

dpkg -i --force-overwrite /var/cache/apt/archives/mint-backgrounds-lisa_1.1_all.deb

You should try as hard as you can not to meddle with the package system by manually removing files from packages or forcing things through dpkg. This usually tends to break the system even further and makes recovery even more difficult.

Broken packages are usually the result of a problem with your repositories: there is either an unresolved conflict between two packages (and in this case one of the packages has a problem or has been tampered with), or a dependency for a package you want to install is not available (although the repository information claims it is).

Also, there seems to be some confusion as to which package has the problem: it is not mint-backgrounds-lisa but mint-artwork-kde. My suggestion to you is to remove the offending package:

# dpkg -P mint-artwork-kde

and then try to run:

# apt-get -f install

so apt can work out the issues and solve the problem by itself.


Run these commands as root

sudo apt-get purge mint-backgrounds-lisa && sudo apt-get install mint-backgrounds-lisa 
sudo dpkg --configure -a

If this doesn't address problem please paste output.

  • I use ~> to represent the command prompt, is this improper format? Dec 31, 2017 at 9:03

A quick and dirty fix, was hack the dpkg records,

Since /usr/share/gnome-background-properties/linuxmint-lisa.xml belongs two packages, you're going to remove it from one,

Goto /var/lib/dpkg/info/mint-artwork-kde.list, remove that xml filename from the file.

And redo apt-get -f install

Notice in the future this package conflicts will be solved by the packager (let's hope), and later updates will not be affected.

  • I deleted this line /usr/share/gnome-background-properties/linuxmint-lisa.xml from this file /var/lib/dpkg/info/mint-artwork-kde.list . However, apt-get install -f is still not happy and still complaining about lisa. EDIT: I removed all the lines with lisa in them and now install -f gives a different error, in fact it refers to it as a Traceback. Guess Mate and KDE don't play well together. Or Mate and Mint.
    – Scooter
    Nov 4, 2012 at 10:58
  • 3
    Tampering with the dpkg records is never a good idea. This issue is better fixed through the available tools in the package system. Manually editing the records may cause even worse problems.
    – Francisco
    Apr 29, 2018 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .