I am running a version of RHCE6 on my laptop, and lately I've been trying various stuff about network configuration through command line. Last night, I tried removing the NetworkManager using

yum remove NetworkManager

from the system, so that I could have more control of the network through the command line. But the result is, I didn't manage to configure the wireless connection through wpa_supplicant , and I need wireless connection during my travel.
I tried to reinstall using :

yum install NetworkManager

Some version installed, but I didn't get an icon in the taskbar, and of course, the network doesn't work. The package I previously removed (about 24MB) was much larger that the one I just installed(about 2MB), I think some dependencies must be missing.

How could I Reinstall network manager correctly to restore my connectivity?

4 Answers 4


To identify discrepancy in packages removed/installed, you can check /var/log/yum.log*. Scroll back to where NetworkManager is removed, and look at all the packages removed with the same datestamp (removed because they depended on NetworkManager).


Did you try bringing up your network 'by hand'? This is easiest if you can be connected by a ethernet cable (non-wireless) just long enough to reinstall Networkmanager. Then it is likely a simple matter of (as 'root', of course):

ifconfig eth0 up
dhclient eth0

If it simply must be via wireless there is a command-line formula which goes:

wpa_supplicant -B -iwlan0 -c/etc/wpa_supplicant.conf -Dwext && dhclient wlan0

Note your driver maybe be other than 'wext'; and all this presumes that you have /etc/wpa_supplicant.conf already set-up.


I know this is an old question, but I hit this problem recently and the answers here helped. I will expand and say when you reinstall NM try:

yum install NetworkManager*

That will pickup the ui packages needed for the applet.

When I parsed my yum logs I found this:

Jun 16 18:54:43 Erased: NetworkManager-gnome
Jun 16 18:54:43 Erased: NetworkManager-openconnect
Jun 16 18:54:44 Erased: NetworkManager

Did you check the Wiki page for NetworkManager

Install :

yum install NetworkManager

Check if running or Start if not:

service NetworkManager status

Start if it's not running:

service NetworkManager start
chkconfig NetworkManager on

Disable network and wpa_supp services as stated in Wiki:

chkconfig network off
chkconfig wpa_supplicant off

And Reboot. To open it's GUI:


UPDATE 1:Check out Reinstall all dependencies of a given package?

  • Thank you for the answer. I've run all the commands you listed, still no avail. Opening the GUI using nm-applet and nm-connection-editor would return "command not found".
    – Yang Jy
    Nov 3, 2012 at 8:12
  • Check with yum whatprovides */nm-applet and yum whatprovides */nm-connection-editor what packages you need to install as well. Nov 3, 2012 at 8:22
  • @YangJy Updated my answer.
    – xperator
    Nov 3, 2012 at 8:39
  • @alexanderJanssen thank you for the comment, as now I have no Internet access on the laptop in question, I'll check your commands later. :)
    – Yang Jy
    Nov 3, 2012 at 10:45
  • @xperator Thank you again, it really helps :)
    – Yang Jy
    Nov 3, 2012 at 10:45

You must log in to answer this question.