0

On Solaris 11.4 when I try to use ls with colors in an SSH session, the output is correctly colored but there is a question mark in a box at the end of every line like this. I tried ssh from both Linux and Windows PC. This problem does not happen on the local Solaris terminal.

$ ls -l --color=auto
total 5453
drwxr-xr-x   2 elliott  staff          3 Aug 27 09:06 aix
-rwxr-xr-x   1 elliott  staff       1168 Aug  6  2012 build_sds.txt
drwxr-xr-x   6 elliott  staff          7 Aug 27 09:06 classes

Can anyone point me in the right direction for fixing this?

0

Double check if TERM is something like 'xterm-color' and if your shell rc was properly loaded. I used to have issues loading ~/.kshrc under ssh session.

  • TERM is xterm-256color and I'm using bash – Elliott B Aug 27 '19 at 23:52
  • Have you tried xterm-color or just xterm ? – ivspenna Aug 28 '19 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.