-1

Now I know Fedora expects the 64-bit and 32-bit versions of libraries to be the same. But I have no idea how to untangle this mess. All things I've tried so far have not worked.

I'm running an x86_64 OS based on Fedora 18.

-bash-4.3# yum install zlib.x86_64
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for libstdc++ which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libstdc++ of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libstdc++.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of libstdc++ installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of libstdc++ installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: libstdc++-4.7.2-8.fc18.x86_64 != libstdc++-5.4.0-7315162.1.i686
Error: Protected multilib versions: pcre-8.31-2.fc18.x86_64 != pcre-8.41.8484923.i686
Error: Protected multilib versions: libselinux-2.1.12-7.fc18.x86_64 != libselinux-2.1.12-7.3.fc18.i686
Error: Protected multilib versions: libgcc-4.7.2-8.fc18.x86_64 != libgcc-5.4.0-7315162.1.i686
Error: Protected multilib versions: nss-softokn-freebl-3.14-5.fc18.x86_64 != nss-softokn-freebl-3.15.3-1.fc18.i686
Error: Protected multilib versions: libcap-2.22-3.fc18.x86_64 != libcap-2.22-5.fc18.i686
Error: Protected multilib versions: glibc-2.16-24.fc18.x86_64 != glibc-2.18-11.fc18.7316798.arminglibc1.2.i686
Error: Protected multilib versions: glibc-common-2.16-24.fc18.x86_64 != glibc-common-2.18-11.fc18.7316798.arminglibc1.2.i686

Running yum update gives me this:

-bash-4.3# yum update
Error: Package: ntp-udel-4.2.6p3-0.1.rc10.fc18.7475906.1.i686 (@local/$releasever)
           Requires: ntpdate = 4.2.6p3-0.1.rc10.fc18.7475906.1
           Removing: ntpdate-4.2.6p3-0.1.rc10.fc18.7475906.1.i686 (@local/$releasever)
               ntpdate = 4.2.6p3-0.1.rc10.fc18.7475906.1
           Updated By: ntpdate-4.2.6p5-5.fc18.i686 (fedora)
               ntpdate = 4.2.6p5-5.fc18
 You could try using --skip-broken to work around the problem
** Found 11 pre-existing rpmdb problem(s), 'yum check' output follows:
i2c-tools-3.1.0-2.fc18.i686 has missing requires of /usr/bin/perl
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl >= ('0', '5.004', None)
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl(Fcntl)
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl(POSIX)
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl(constant)
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl(strict)
i2c-tools-3.1.0-2.fc18.i686 has missing requires of perl(vars)
1:ndisc6-1.0.3-2.fc18.i686 has missing requires of /usr/bin/perl
1:ndisc6-1.0.3-2.fc18.i686 has missing requires of perl(Getopt::Std)
1:ndisc6-1.0.3-2.fc18.i686 has missing requires of perl(strict)
1:nginx-1.12.1-7352333.diagsdevbasetrunk.1.i686 has missing requires of perl(:MODULE_COMPAT_5.16.3)

1 Answer 1

0

Looks like your have 32bit libraries newer than your 64bit libraries. Most of time this happens when mixing third party libraries, so be careful.

You could try to install only the required 64bit libraries on your system, one by one.

But if even doing this you still unable to install zlib, you could try to remove duplicates with package-cleanup --cleandupes and retry to resume your installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.