0

I need to install MySmartUSB Light in linux LMDE 3 Cindy as programer for avr in linux,so i downloaded this driver (Linux_3.x.x_4.x.x_VCP_Driver_Source) from this link: based of it's note shown below:

Last modified July 12, 2019

This bundle contains a modified CP210x driver for the 4.10.0 kernel (Ubuntu 17.04).

It contains:

  • Support for the CP2102N

NOTE: This driver is an example of how to perform GPIO operations within the CP210x driver since the driver on kernel.org does not support GPIO at this time. This driver has only been written and tested on the Linux 3.13.0 kernel on Ubuntu 14.04. This driver is a modified version of the existing driver in the Linux 3.13.0 kernel, which is maintained at kernel.org. It is recommened to use the driver there that matches your specific kernel version:

www.kernel.org

Build instrutions:

Ubuntu: 1. make ( your cp210x driver ) 2. cp cp210x.ko to /lib/modules//kernel/drivers/usb/serial 3. insmod /lib/modules/

When i want to run sudo make in the driver folder i get this error:

so@notebook:~/Downloads/Compressed/Linux_3.x.x_4.x.x_VCP_Driver_Source$ sudo make
[sudo] password for so:        
Sorry, try again.
[sudo] password for so:       
make -C /lib/modules/`uname -r`/build M= modules
make[1]: Entering directory '/usr/src/linux-headers-4.9.0-9-amd64'
/usr/src/linux-headers-4.9.0-9-common/scripts/Makefile.build:44: /usr/src/linux-headers-4.9.0-9-common/scripts/basic/Makefile: No such file or directory
make[5]: *** No rule to make target '/usr/src/linux-headers-4.9.0-9-common/scripts/basic/Makefile'.  Stop.
/usr/src/linux-headers-4.9.0-9-common/Makefile:444: recipe for target 'scripts_basic' failed
make[4]: *** [scripts_basic] Error 2
/usr/src/linux-headers-4.9.0-9-common/scripts/Makefile.build:44: /usr/src/linux-headers-4.9.0-9-common/arch/x86/entry/syscalls/Makefile: No such file or directory
make[4]: *** No rule to make target '/usr/src/linux-headers-4.9.0-9-common/arch/x86/entry/syscalls/Makefile'.  Stop.
arch/x86/Makefile:231: recipe for target 'archheaders' failed
make[3]: *** [archheaders] Error 2
Makefile:152: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.9.0-9-amd64'
Makefile:7: recipe for target 'all' failed
make: *** [all] Error 2

SO how could i solve this problem?

1

Have you used this system to run make to build drivers before? It's possible you need a few extra packages.

This guide might be somewhat helpful as it describes the necessary steps prior to compiling a software package, although the most important step in your case is probably the first:

sudo apt-get install build-essential checkinstall

Once this is run, try compiling the drivers with sudo make again.

If it doesn't work, it's possible you don't have the proper kernel headers. Kernel headers are basically just the C header files for the kernel itself, which is necessary for compilation of things that interface with the kernel (such as the drivers). Here is an installation guide which explains that upgrading/installing the kernel headers is as easy as running:

sudo apt update
sudo apt install linux-headers-$(uname -r)
| improve this answer | |
  • It's work ,thanks a lot. – modern Aug 27 '19 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.